Bug 296711 - firstboot --reconfig tracebacks
firstboot --reconfig tracebacks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
: 241325 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-19 13:53 EDT by Matthias Clasen
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 11:12:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2007-09-19 13:53:43 EDT
running firstboot --reconfig gives me the following:

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 497, in loadModules
    result = module.launch()
  File "/usr/share/firstboot/modules/timezone.py", line 74, in launch
    self.setupScreen()
  File "/usr/share/firstboot/modules/timezone.py", line 52, in setupScreen
    self.timezoneWindow = scdMainWindow.scdMainWindow (firstboot = True,
showPages = ["timezone"])
  File "/usr/share/system-config-date/scdMainWindow.py", line 266, in __init__
    self.datePage = date_gui.datePage (self.dateBackend, self.xml)
  File "/usr/share/system-config-date/date_gui.py", line 65, in __init__
    self.cal.select_month(times[1]-1, times[0])
AttributeError: 'NoneType' object has no attribute 'select_month'


Since there is a problem with the Timezone module, 
Red Hat Setup Agent will not load this module and 
will attempt to run the remaining modules.

Please file a bug against 'firstboot' in the Red Hat 
bug tracking system at http://www.redhat.com/bugzilla. 
A copy of the debug output has been saved to /root/firstboot.1190224261.15 
Be sure to attach that file to the bug report.
Comment 1 Nils Philippsen 2007-10-05 05:01:02 EDT
This seems to be a firstboot-specific problem. "All is well" when running
/usr/share/system-config-date/system-config-date.py directly (and I haven't done
anything to the calendar widget in ages).
Comment 2 Nils Philippsen 2007-10-05 11:12:04 EDT
Fixed stupid code in scdMainWindow.py that removed the widget along with
parents, system-config-date-1.9.11-1.fc8 is building right now.
Comment 3 Nils Philippsen 2007-10-09 11:48:41 EDT
*** Bug 241325 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.