Bug 29691 - filesystems not umounted cleanly after install completes
Summary: filesystems not umounted cleanly after install completes
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-27 02:15 UTC by Ben Levenson
Modified: 2007-03-27 03:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-05 20:18:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Levenson 2001-02-27 02:15:28 UTC
build: qa0226.0
GUI-NFS-Workstation

hardware: HP Eagle (in lab)
PIII 600/256M RAM
adaptec (aic78xx) present, but cdrom and hard drive
are on IDE.

filesystems are not cleanly unmounted at the end of the installation.
check forced during system reboot.

steps to reproduce:
1- NFS-GUI install
2- complete a default installation
3- type <enter> at final install screen (or click on appropriate button).
4- system reboots immediately -- none of the expected messages
regarding unmounting filesystems are flashed on the screen.
5- filesystem check forced during next boot.

I can only reproduce this failure on the above system.
Text HTTP (custom-minimal) and NFS (custom-minimal, workstation)
completed successfully.

Comment 1 Glen Foster 2001-02-27 21:50:05 UTC
See Preston about how to proceed troubleshooting/investingating this ASAP.

Comment 2 Glen Foster 2001-03-02 18:02:55 UTC
This defect determined (by Michael Fulbright) to be MUST-FIX for Florence Gold
release.

Comment 3 Erik Troan 2001-03-05 18:21:15 UTC
Unless we can reproduce this, we can't fix it. Brock, have you seen this?

Ben's report suggests that this exit path is bypassing init; I don't know why
this would happen.

Comment 4 Michael Fulbright 2001-03-05 19:44:28 UTC
I have not seen this issue myself.  We should close it NOTABUG if it does not
turn up by the Gold date.

Comment 5 Ben Levenson 2001-03-05 20:14:07 UTC
the problem was nearly 100% reproducible with the HP Eagle in the lab,
but it appears to have fixed itself in the qa0301.0.  
I'll update the bug if it happens again.

Comment 6 Matt Wilson 2001-03-05 20:18:20 UTC
yes, I worked on this one for hours - I could never catch the offending bit that
cause the whole machine to reboot when you hit OK.  No output on console (oops)
or anything.  It seems to have gone away now, though.


Comment 7 Ben Levenson 2001-04-05 23:38:30 UTC
as I said above, this failure has only occured on a specific
system in the test lab.  It hasn't been misbehaving since
early March and the system has been tested with about every
tree since then....
closing.



Note You need to log in before you can comment on or make changes to this bug.