Bug 296971 - New /usr/bin/run-parts badly broken
Summary: New /usr/bin/run-parts badly broken
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: crontabs (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
urgent
urgent
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-19 21:23 UTC by Terje Røsten
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 07:40:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Terje Røsten 2007-09-19 21:23:53 UTC
These added lines in /usr/bin/run-parts:

AUX1=`cat /var/spool/anacron/cron.daily`
AUX2=`date +%Y%m%d`
[ "$AUX1" == $AUX2 ] || exit 0

is bogus. It's normal to use vixie-cron without anacron.
On my systems anacron is not even installed and the file
/var/spool/anacron/cron.daily don't even exists!

Result is that /usr/bin/parts will exit on every run and no cron jobs will
be executed. For a crond based update/patching system this is really bad.
The patch from #295811 should be applied and a new updated package
should be released very soon.

Thanks!

Comment 1 Terje Røsten 2007-09-20 07:40:26 UTC
Seems to be fixed for F7 already, however why is this not fixed in rawhide?




Note You need to log in before you can comment on or make changes to this bug.