Bug 29712 - USB disconnect causes kernel hang
USB disconnect causes kernel hang
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-26 23:43 EST by Derek Price
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-23 08:00:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Price 2001-02-26 23:43:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-3-usb i686)


I have a combination Video/USB switch attached to my machine.  With the new
(2.2.17-14) kernel, a USB disconnect from the 4 port hub/switch hangs the
kernel.  I ran, 'tail -f /var/log/messages' before I performed the
disconnect last time and no messages about the disconnect appeared, so I am
assuming that the hang happened on disconnect and not reconnect.  (I
wouldn't know the difference otherwise as the disconnect also disconnects
the monitor).

Reproducible: Always
Steps to Reproduce:
1. Boot 2.2.17-14 with a USB device attached.
2. Disconnect it.
3.
	

Actual Results:  Kernel hung.  Even the second hand on the clock stopped.

Expected Results:  Kernel should have kept running and on reconnect of the
USB hub should have noticed and reenabled the USB devices.

Have a 4 port USB hub/KVM switch attached with three devices - a keyboard,
a mouse, and a QuickCam.

I'm guessing the USB controller is OHCI since the bios can be set to make a
USB keyboard look like a PS/2 keyboard and the keyboard is usable from lilo
with or without this feature enabled.
Comment 1 Pete Zaitcev 2002-06-03 14:01:49 EDT
Eek. Can you upgrade to 7.3?
Comment 2 Derek Price 2002-07-23 08:00:44 EDT
That's my server machine, so I don't upgrade it quite as often as my laptop, but
it's been running 7.2 for some months and I haven't seen any more problems. 
It's hardly scientific, as I haven't been using it from the console as much
recently, but it used to crash fairly often and the uptime's currently 40 days.
Comment 3 Pete Zaitcev 2002-07-23 12:58:41 EDT
OK, 7.2 is good enough. It's only important to move off the 2.2
kernel, because it did not have right USB at all. We kinda sorta
made it working for most cases, but it was a kludge. For instance,
SMP was guaranteed to deadlock.

If the 7.2 keels over for you, open a new bug, I'll look.

Note You need to log in before you can comment on or make changes to this bug.