Bug 29719 - rpm 4.0.2 configure doesn't search for DB 3.x as just db.h
Summary: rpm 4.0.2 configure doesn't search for DB 3.x as just db.h
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.3
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL: ftp://dogbert.cc.ndsu.nodak.edu/pub/r...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-27 07:32 UTC by Red Hat Bugzilla
Modified: 2008-03-13 19:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-27 14:29:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Red Hat Bugzilla 2001-02-27 07:32:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; OSF1 V5.0 alpha)


configure for rpm 4.0.2 and a couple of the lib/db* files are coded such
that they work fine on Red Hat systems, where the DB 3.x header file is in
db3/db.h, but
on other systems where that probably just gets installed under
${prefix}/include/db.h, db3.c and dbconfig.c won't compile, because they
blindly try include db3/db.h if USE_DB3 is defined.

A slightly more portable way of doing this is check for db3/db.h, and if
it's not found, then check for just db.h.  If that is found, check it to
see if it defines
the DB_VERSION_MAJOR as 3.  If it does, then define a couple symbols so
that db3.c and dbconfig.c know that they can include just db.h and get the
stuff
they need.

Reproducible: Always
Steps to Reproduce:
DB 3.x on any non-Red Hat system:

./configure ; make ; make install

followed by:

./configure; make

with rpm 4.0.2	

The URL contains a patch I've coded up that does what I mention in the
description above. 

Note that patch also contains one other tune-up -- don't force configure's
notion of a proper PATH when searching for various tools for any platform
other
than linux.

Comment 1 Red Hat Bugzilla 2001-02-27 14:29:25 UTC
rpm is gonna swallow a copy of Berkeley DB, there's simply too many issues to
be dealt with building against a j-random db installation.

Meanwhile, thanks for the patch.

You might also be interested in looking at rpm top of stack. There's a
--repackage
option as in
	rpm -Uvv --repackage <your packages here>
that puts the old bits back into packages in (configurably) /var/tmp.

There'll be a full blown --apply/--commit/--rollback methodology Real Soon Now.

Comment 2 Red Hat Bugzilla 2001-05-21 19:56:22 UTC
rpm-4.0.3 has swallowed db-3.3.4,  will not have support for db1, so this
problem is moot.


Note You need to log in before you can comment on or make changes to this bug.