Bug 29724 - screen dies after unlocking
screen dies after unlocking
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: screen (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-27 05:03 EST by David Balažic
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-16 10:04:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Balažic 2001-02-27 05:03:25 EST
screen-3.9.8-2

Steps to reproduce :

1. run screen as root on VT1
2. open some virtual screens
3. lock screen ( ctrl-a ctrl-x )
4. wait a few minutes
5. unlock it by entering the password
6. boom, screen exits and the terminal is hosed
   The virtual terminals are still alive and can be reattached
   VT1 does not echo any user input, not even "ENTER", but it responds
   to it, and output seem to be unaffected. Sanity is restored
   by "stty sane"
Comment 1 David Balažic 2001-03-05 07:08:32 EST
Same with screen-3.9.8-3 ( in Wolverine )
Comment 2 David Balažic 2001-03-22 09:16:38 EST
It happened also when I ulocked right after locking,
so it might not be time related.
I noticed in the source that the password is read by getpass(3),
which is obsolete, according to man page.
getpass() disables echo which is one of the simptoms, so maybe
this is getpass() crashing.
Comment 3 David Balažic 2001-04-26 04:26:11 EDT
The bug is still there in Seawolf , screen-3.9.8-3
Comment 4 Crutcher Dunnavant 2001-06-26 18:12:36 EDT
works for me with 3.9.9
Comment 5 David Balažic 2001-07-26 06:28:46 EDT
I experince the bug with screen-3.9.9-1 on a RH 7.1 system.
Notice that it doesn't happen always , but most of the time !
Comment 6 David Balažic 2002-04-10 11:15:54 EDT
I experienced the same problem with screen-3.9.10-1 in 
redhat 7.2.93 ( skipjack2 ).
Comment 7 Lon Hohberger 2002-11-07 16:28:33 EST
Is this still a problem on 7.3 or 8.0?  

I haven't been able to reproduce it on 8.0.  If it's present on 7.3/8.0, I'll
look more into it.  Otherwise, I'll assmume it's good, otherwise I'd like to
close it.
Comment 8 Lon Hohberger 2002-12-16 16:33:40 EST
Any activity here?  Could this be related to the UTF-8 problems seen in versions
prior to 3.9.13?

ftp://ftp.redhat.com/pub/redhat/linux/rawhide/RedHat/RPMS/screen-3.9.13-2.i386.rpm
Comment 9 Lon Hohberger 2003-04-16 10:04:44 EDT
I believe this was fixed with 3.9.11's UTF8 fixes.  Here's a pointer to the
latest packaged screen, which has more UTF8 bugfixes as well:

http://people.redhat.com/lhh/screen-3.9.15-1.i386.rpm
http://people.redhat.com/lhh/screen-3.9.15-1.src.rpm

The above packages should be available in rawhide soon.

Reopen bug if it is still present - I've been unable to reproduce it.

Note You need to log in before you can comment on or make changes to this bug.