Bug 297431 - blacklist evolution-devel from multilib
blacklist evolution-devel from multilib
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mash (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-20 00:51 EDT by Jens Petersen
Modified: 2014-03-16 23:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 22:45:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2007-09-20 00:51:07 EDT
Description of problem:
Can evolution not be multilib for F8?
I think it would be nice to blacklist evolution-devel
unless there is a good reason not too?
Comment 1 Jesse Keating 2007-09-20 09:45:49 EDT
Is there a good reason /to/ blacklist it?  Blacklists are just hacks that have
to be carried around in any tool that has a part in this.  We generally only
blacklist if there is a genuine problem with having it multilib.
Comment 2 Jens Petersen 2007-09-20 20:59:48 EDT
What is the point of having evolution multilib?

For F9 IMHO we should really stop having multilib trees IMHO
and just let yum sort it out from the i386 and x86_64 repos for
those that want it.  Quite a number of Fedora people seem to agree
that this is the right way to go.
Comment 3 Jens Petersen 2007-09-20 21:01:32 EDT
Reasons to not multilib include it is installed by default on the
desktop, it is pretty big, having it multilib seems meaningless,
and it is a waste of bandwidth for updates and diskspace etc.
Comment 4 Bill Nottingham 2007-09-20 21:10:07 EDT
The plan is already to split things out for F9. However, adding more blacklists
just because isn't the answer - it leads to unmaintainable lists.
Comment 5 Bug Zapper 2008-04-04 09:52:52 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 6 Jens Petersen 2008-04-14 22:33:22 EDT
evolution-devel still seems to be multilib in current pre-F9 rawhide.
Comment 7 Bill Nottingham 2008-04-14 22:45:07 EDT
There is multilib_policy if you want less multilib by default; I don't see logic
as to how having it multilib specifically breaks anything, so I don't see a
reason to change this in mash.

Note You need to log in before you can comment on or make changes to this bug.