Bug 29748 - Problem with XFREE86 and Cirrus no name card
Problem with XFREE86 and Cirrus no name card
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-27 10:29 EST by Ed Thibeault
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-05 19:00:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Thibeault 2001-02-27 10:29:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)


Problem with XFREE86 and Cirrus no name card. Installer reconizes card but 
when testing (Cirrus no name with 2MB and Pnasonic TX-D1752U monitor) 
system loads grey screen and cursor but never diplays test screen and 
system then hangs. Only way around is a reboot.

Reproducible: Always
Steps to Reproduce:
1. Select Cirrus no name card from database
2. Select Panasonic Monitor
3. Run test xconfig
	

Actual Results:  Screen just displays grey screen and cursor. Reboot 
required to clear error

Expected Results:  Should display test menu so you can say yess I see it 
or error out.
Comment 1 Mike A. Harris 2001-03-02 22:09:15 EST
Try using XFree86 4.0.2 instead.

Xconfigurator --preferxf4

I thought 4.x was the default for all Cirrus Logic cards, however perhaps
I was wrong..

If the above does not work for you, please report back here.
Comment 2 das_deniz 2001-03-05 19:00:20 EST
reporting user was describing hang during installation.
I also had this problem with the fisher release.
during installation i would choose the bit depth and
resolution (that i currently run 7.0 with) and click
the 'test' button. then the background x grid at that
resolution would start up but the "click if settings
appear to be working ok" or timeout dialogue would
never appear -- and a reboot was required.

i have a virge/dx chipset (diamond stealth 3d 2000 pro)
and a nokia 446Xpro monitor.

this bug seems to have been corrected in the wolverine release
of the installer (anaconda - is where this bug should have been
posted -- right?)

das
Comment 3 Mike A. Harris 2001-03-13 22:31:41 EST
Aparently, this problem is fixed, in Wolverine, so I'm closing it.
I couldn't reproduce on either of 3 Cirrus logic cards under Wolverine
so it perhaps was fixed by anaconda, or via an XFree86 CVS sync.
Comment 4 Need Real Name 2001-04-05 10:40:45 EDT
All,
   I just upgraded via the Wolverine ISOs, and had the same problem. I have a
Soyo system with Cirrus 544x 2MB PCI video.  All the probe guesses are propper
for both video card and monitor (amazing!) but like the earlier report, any
startup of XFree past that point crashes the system hard.  
   IE, the graphic installer Xwindow works fine, but the X configuration test
crashes the system.  If I skip the test and let the install complete, it crashes
as soon as the graphic logon begins.
   I see above the recommendation to use XFree86-4.0.2, but that's what came on
the Wolverine ISO already, so no joy there.
   I also tried the Xconfigurator --preferxf4 mojo, but nothing there either.
   Now the status of this bug is shown as "Rawhide" which component do I need to
try to upgrade, since XFree is already at 4.0.2 on Wolverine?

Note You need to log in before you can comment on or make changes to this bug.