Bug 297531 - samba causes error "smbldap_open: cannot access LDAP when not root.."
samba causes error "smbldap_open: cannot access LDAP when not root.."
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba (Show other bugs)
5.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Guenther Deschner
qe-baseos-daemons
http://bugs.centos.org/view.php?id=2338
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-20 04:20 EDT by Jean-Luc PIPO
Modified: 2010-11-09 08:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 10:31:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 4097 None None None Never

  None (edit)
Description Jean-Luc PIPO 2007-09-20 04:20:17 EDT
Description of problem:
On shared directories that contains ACLs, samba causes the error "smbldap_open:
cannot access LDAP when not root.." on every ACL access in /var/log/messages.

Version-Release number of selected component (if applicable):
3.0.23c (redhat current)

How reproducible:
Just share a directory with ACLs and options 'inherits permissions', 'inherits
acls' and 'inherits owner'
  
Actual results:
Slow the Samba Server

Additional info:
This is a known issue in samba 3.0.23c that is corrected in the patch
https://bugzilla.samba.org/show_bug.cgi?id=4097
Comment 1 Simo Sorce 2007-09-24 09:27:07 EDT
We have a new version of samba in the Beta channel.
This version fixes a number of errors like the one reported.
If you can try it and report if it is fixed, that would be great.

Thanks.
Comment 2 Andrew Cartwright 2007-12-12 21:07:34 EST
Has this issue been properly resolved yet?

I am also experiencing this problem and it's a real problem as it causes file 
access difficulties.  This is particularly noticeable on Excel files where they 
permissions are changed to read-only.
For these files in a shared directory it then makes then unusable unless I 
intervene and modify permissions/acls which is quite disruptive.

I'm currently running samba 3.0.25b (RHEL 5 x86_64)
Comment 7 Natalia K 2008-11-14 12:05:21 EST
I have the same error message showing up in machine smbd logs. I added machine to the domain successfuly. However, when I try to login on using a domain account on the added machine. It fails. The error message shows up: The system cannot log you on now because the domain ____ is not avaliable. Any ideas, what I am doing wrong ?. I am using samba 3.2.0 release 1.pre3.9.fc9 and Fedora directory server 1.1.1 release 3.fc9. 

Thank you 

Any help would be highly appreciated.
Comment 9 Simo Sorce 2009-09-02 19:06:29 EDT
Guenther can you look into this one ?

Simo.
Comment 11 Dmitri Pal 2010-04-26 10:31:14 EDT
Should be already addressed in the latest versions of the package.

Note You need to log in before you can comment on or make changes to this bug.