This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 29786 - Wrong ps/2 mouse detection
Wrong ps/2 mouse detection
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kudzu (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-27 12:34 EST by Sammy
Modified: 2014-03-16 22:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-27 12:34:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sammy 2001-02-27 12:34:20 EST
After the latest upgrade (Rawhide Feb. 26) when I rebooted kudzu
reported that my mouse was removed and then added a mouse....all is 
fine except the added mouse was not the right device. I am not sure
how wide this problem is but it may worth taking care of:

I had a link /dev/mouse --> /dev/sgc which itself was a link to /dev/sg2

this was working until now....but now mouse is switched to /dev/psaux
(I am not sure who/what does this...not the kernel since that has not
changed...I am using my own 2.4.1 kernel).

So, device /dev/mouse was left undefined and starting scripts for gpm
and xf86 failed. The only way I could solve this was to delete /dev/sgc
and link /dev/mouse to /dev/psaux....if I did not delete /dev/sgc
kudzu kept showing that as the device!

FYI
Comment 1 Bill Nottingham 2001-02-27 13:16:33 EST
Fixed in 0.96.15 or so.

Note You need to log in before you can comment on or make changes to this bug.