Bug 29806 - Fatal RPM error reading header from package
Summary: Fatal RPM error reading header from package
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date   
(Show other bugs)
Version: 4.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-27 18:38 UTC by Need Real Name
Modified: 2015-01-07 23:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-07 13:51:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-02-27 18:38:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i586)


Click next on initial Update screen.
Box opens for getting package information.
After a few minutes an error box opens with the above error message.
Click OK and Up2date closes.

Reproducible: Always
Steps to Reproduce:
1.See description
2.
3.
	

Actual Results:  Error box was displayed, after clicking OK button then
up2date closes.

Expected Results:  List of packages available for upgrade should have been
displayed

Seems to have started happening since RHN updates were carried out on the
26th Feb.

Comment 1 Preston Brown 2001-02-28 11:12:38 UTC
transient server error, since fixed.

Comment 2 Need Real Name 2001-03-01 18:11:55 UTC
Sorry - still happening on 1st March 2001

Comment 3 Need Real Name 2001-03-06 18:30:40 UTC
Is there an update on this please. I still get the error on 6th March 2001. I
can not use up2date at all.

Comment 4 Jay Turner 2001-03-07 13:51:44 UTC
Here's one thought.  Go to the /var/spool/up2date directory on the machine and
delete any files that are in there.  Up2date will try to use any files in this
directory instead of redownloading them from the network.  There is a good
chance that you have a corrupt header file in there.  We are trying to come up
with the best solution for that problem, as it is not an easy one to solve.  So,
delete any files which are in that directory then rerun up2date and see if you
get better results.

Comment 5 Need Real Name 2001-03-07 18:46:30 UTC
Thanks, clearing out /var/spool/up2date cleared the problem. Bug report can be
closed.


Note You need to log in before you can comment on or make changes to this bug.