Bug 298631 - [mmconf] Kernel freeze during PCI bus probing on DG33TL Intel MotherBoard
[mmconf] Kernel freeze during PCI bus probing on DG33TL Intel MotherBoard
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-20 13:27 EDT by Jérôme Benoit
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: ernel-2.6.23.1-49.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-11 11:25:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmi decode output (8.90 KB, text/plain)
2007-09-20 13:27 EDT, Jérôme Benoit
no flags Details
cpuinfo output (1.16 KB, text/plain)
2007-09-20 13:33 EDT, Jérôme Benoit
no flags Details
lspci -v output (9.31 KB, text/plain)
2007-09-20 13:34 EDT, Jérôme Benoit
no flags Details

  None (edit)
Description Jérôme Benoit 2007-09-20 13:27:06 EDT
Description of problem:

See "Summary" of the bug.

Version-Release number of selected component (if applicable):

kernel-2.6.22.5-76.fc7 or kernel-2.6.21-1.3194.fc7

How reproducible:

Always.

Steps to Reproduce:
1. Having the hardware (see http://www.intel.com/products/motherboard/DG33TL/
for more information) with latest BIOS version installed
2. Boot from USB stick w/o kernel parameters the liveCD of F7 i386 or x86_64
  
Actual results:

See the freeze happening.

Expected results:

No freeze.

Additional info:

I must boot with pci=nommconf kernel parameters to finish install from USB stick
(F7 i386 and x86_64). 

I'm having other troubles with kernel on this hardware, other bugs will follow
regarding support for this MotherBoard. Not enough time ...
Comment 1 Jérôme Benoit 2007-09-20 13:27:06 EDT
Created attachment 201011 [details]
dmi decode output
Comment 2 Jérôme Benoit 2007-09-20 13:32:55 EDT
FYI, the USB stick installation method was chosen because of an other freeze due
to pata_it821x module (DVD install method from PATA on board chipset). An other
bug report will follow.  
Comment 3 Jérôme Benoit 2007-09-20 13:33:41 EDT
Created attachment 201021 [details]
cpuinfo output
Comment 4 Jérôme Benoit 2007-09-20 13:34:07 EDT
Created attachment 201031 [details]
lspci -v output
Comment 5 Christopher Brown 2007-10-03 11:37:58 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

This bug has been marked as possibly resolved in 2.6.23 - could you do so when
it becomes available (or even install a 2.6.23 rawhide kernel if you are able
to) and advise whether it works for you.
Comment 6 Jérôme Benoit 2007-10-03 12:11:11 EDT
I can confirm that 2.6.23*-git-* vanilla kernel do not work better regarding PCI
bus probing with mmconfig (almost same .config that's the one shipped is F7
kernel SRPM). 

Haven't tested Fedora rawhide kernel ...

Cheers.

Comment 7 Christopher Brown 2007-10-04 05:56:45 EDT
The developers will need you to test with a fedora kernel as opposed to vanilla.
The config may be *close* but the patches include are numerous and it is what
they work from. If you can test with a fedora kernel therefore that would be great.
Comment 8 Jérôme Benoit 2007-11-11 11:25:35 EST
I'm closing this bug because mmconfig has been disabled in Fedora 8 kernel.

Note You need to log in before you can comment on or make changes to this bug.