Bug 298661 - Anaconda (mkinitrd?) fails to create initrd for root on LV
Anaconda (mkinitrd?) fails to create initrd for root on LV
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-09-20 13:36 EDT by Clyde E. Kunkel
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 16:32:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log from failed install (56.45 KB, text/plain)
2007-09-20 13:36 EDT, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2007-09-20 13:36:00 EDT
Description of problem:
Anaconda (or mkinitrd?) does not create an initrd image that starts all software
raidsets  needed for LVs

Version-Release number of selected component (if applicable):
anaconda 11.3.0.28

How reproducible: every time


Steps to Reproduce:
1. boot i386 FC8T2 DVD
2. specify NOMPATH (have to do to even get anaconda to see all raids and LVs)
3. select create custom partitioning
4. create layout with / on an LV
5. install with default software
6. first boot fails during initrd with / LV not being found
  
Actual results: 6 above


Expected results: normal install


Additional info:

This bug was presernt with FC7T3 and final, but specifying NOMPATH allowed
workaround.  A BZ (237456) was entered, but not resolved since workaround
existed. Tried NODMRAID, but didn't work at all during install LV detection.

I also went to console 2 and manually started all raidsets with mdadm.

Attaching anaconda log from install.
Additional info:
Comment 1 Clyde E. Kunkel 2007-09-20 13:36:00 EDT
Created attachment 201041 [details]
anaconda log from failed install
Comment 2 Jeremy Katz 2007-10-10 15:22:47 EDT
Were you reusing a pre-existing LV?
Comment 3 Clyde E. Kunkel 2007-10-12 16:03:18 EDT
Yes.
Comment 4 Jeremy Katz 2007-10-12 16:32:14 EDT
Okay, then this is the bug that Chris fixed up yesterday.

Note You need to log in before you can comment on or make changes to this bug.