Bug 298871 - unable to get keys out of gnome-keyring; causes nm-applet to segfault
unable to get keys out of gnome-keyring; causes nm-applet to segfault
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Alexander Larsson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Test3
  Show dependency treegraph
 
Reported: 2007-09-20 14:42 EDT by Jesse Keating
Modified: 2013-01-09 21:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-28 15:16:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2007-09-20 14:42:45 EDT
With a keyring created after F8 Test2, applications are not able to get data out
of the keyring, or they dont' think they did and repeatedly prompt for the
passphrase.  Apps like nm-applet actually seg-fault.
Comment 1 Alexander Larsson 2007-09-21 04:36:19 EDT
I saw the nm-applet crash, but then i updated it to get debuginfo, and the new
version is acting generally weirdly, so i can't reproduce it. (In fact, i can't
find my wireless network even!)

Did you see this in any other app?
Comment 2 Alexander Larsson 2007-09-21 05:02:14 EDT
Ok. This is due to a change in gnome-keyring behaviour.
When searching for an item that doesn't exist it used to return a DENIED error.
This is a bit weird, as that indicates that the item exists, but the user
doesn't have access to it. 

So, in the bug http://bugzilla.gnome.org/show_bug.cgi?id=447315
This was changed to return a non-error result, but a list of zero items.
nm-applet doesn't look at the list and promptly dereferences the list.

A patch for nm-applet is availible in the ubunty bug:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/121228
(Patch is at http://launchpadlibrarian.net/8137066/01_fix_keyring_crash.patch)

Did you see this for any other apps? If so we should fix them too.

CCing dcbw for network manager feedback.
Comment 3 Jesse Keating 2007-09-21 07:58:45 EDT
I'm told that evolution would cycle over and over again when trying to get keys
out, so it also is likely not updated to handle the new return value.

Unfortunately I don't have anything else that uses the keyring.
Comment 4 Dan Williams 2007-09-21 10:12:55 EDT
Patch applies to 0.6.x applet; I think 0.7 should be OK here because it does "if
(g_slist_length (found_list) == 0)" which should work fine with a NULL found
list.  So if we ship with 0.6.x in F8 I'll make sure the patch gets in, and if
we ship with 0.7 I think we're OK.
Comment 5 Jesse Keating 2007-09-28 15:16:29 EDT
This no longer happens, closing.

Note You need to log in before you can comment on or make changes to this bug.