Bug 29907 - rpm-4.0.2 tools/rpmsort build problem on alpha-dec-osf
Summary: rpm-4.0.2 tools/rpmsort build problem on alpha-dec-osf
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-27 23:00 UTC by Red Hat Bugzilla
Modified: 2008-03-13 19:18 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-27 23:10:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Red Hat Bugzilla 2001-02-27 23:00:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; OSF1 V5.1 alpha)


rpm 4.0.2's configure never checks for the presence of `errx', and as far
as I can see
there's no current way for misc/err.c to ever automatically be compiled and
linked
into libmisc.a, if it's needed.

This turns out to be a problem, because errx is used in rpmsort 

Reproducible: Always
Steps to Reproduce:
./configure ; make

on a system without errx.

I see that configure.in is looking for err.h, but it never
looks to see if errx() itself is available.  Should it?

Comment 1 Red Hat Bugzilla 2001-02-27 23:10:21 UTC
Sure would like to use errx, but portability prevents.

Meanwhile, one of these days, I'll rip out whatever remnants off errx that
remain. Hack on
tools/Makefile.am to skip bad players, there's nothing in tools that is needed.

Comment 2 Red Hat Bugzilla 2001-04-03 14:43:22 UTC
Fixed (by not compiling rpmsort by default) in rpm CVS, should be in
rpm-4.0.3-0.4 and later.


Note You need to log in before you can comment on or make changes to this bug.