Bug 2991 - Bug with fs/select.c
Bug with fs/select.c
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-23 20:50 EDT by kumarsri
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-02 18:11:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kumarsri 1999-05-23 20:50:19 EDT
There is a bug with fs/select.c which break the
Informix database (7.30UC2) on Redhat 6 (as well as other
2.2. kernels).

They have changed sys_select considerably and probably
did not know that some programs depend heavily on it -
cannot return errors when there were none before without
checking!

Here's the code:

Search for the function
sys_select
and look for the lines:
 if (n < 0 || n > KFDS_NR)
        goto out_nofds;

This breaks Informix as it passes n as 4096 while
NR_OPEN is 1024!

Please assist in fixing this. Changing NR_OPEN in
linux.h from 1024 to 5120 etc. does more damage!
You cannot mount cdroms etc. after that.

Thanks
/Kumar
Comment 1 kumarsri 1999-05-24 19:45:59 EDT
Fixed - the problem was with Redhat 5.2 and Caldera OpenLinux 2.2

Redhat 6.0 - it's fixed already.

Sorry for the noise!
/Kumar
Comment 2 Cristian Gafton 1999-07-02 18:11:59 EDT
Bug closed (it seems that it is already fixed)

Note You need to log in before you can comment on or make changes to this bug.