Bug 299151 - RFE: Document bind mount format in fstab manpage
RFE: Document bind mount format in fstab manpage
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: util-linux-ng (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-20 15:56 EDT by Eric Sandeen
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-04 09:19:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upstream patch (2.68 KB, patch)
2007-10-04 09:19 EDT, Karel Zak
no flags Details | Diff

  None (edit)
Description Eric Sandeen 2007-09-20 15:56:29 EDT
After looking at Bug 151533: fsck tries to read directories as block devices
with some bind mount setups, Ted said that since a malformed bind mount line in
fstab was the root of the problem, perhaps the bind mount format should be
documented in the fstab or mount man pages. Thoughts?

to me,

/orig   /mountpoint    none   bind   0 0

makes most sense...

(as a side point, for bind mounts, mount doesn't seem to care at all what's in
the filesystem field.... should it?  should it enforce "none?")

Thanks,

-Eric
Comment 1 Karel Zak 2007-10-04 09:19:05 EDT
Created attachment 215811 [details]
upstream patch

This is committed patch for v2.14.

Note You need to log in before you can comment on or make changes to this bug.