This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 29949 - module e100 does not compile with kernel-source-2.2.17-14
module e100 does not compile with kernel-source-2.2.17-14
Status: CLOSED DUPLICATE of bug 29947
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-27 20:12 EST by Marius ILIOAEA
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-27 20:12:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marius ILIOAEA 2001-02-27 20:12:47 EST
Problem: After upgradind to kernel-souce-2.2.17-14 from the RedHat 
Network, module
   "EtherExpressPro/100 support (Intel driver)" (module e100)
wouldn't compile any more.

Cause: The cause is the missing of the necesary lines from from
   /usr/src/linux-2.2.17/drivers/drivers/net/Makefile

Solution: You can copy-paste the missing lines from the Makefile from the 
kernel-source-2.2.16 (included in distribution) or use the diff below:

651a652,655
> ifeq ($(CONFIG_E100),m)
>   M_OBJS += e100.o
> endif
> 
1414a1419,1420
> e100.o: e100.c e100.h
> 	$(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(INCLUDE) -DEXPORT_SYMTAB -c -o 
$*.o $<
! there is a tab and not spaces at the beginning of last line ! 

Note: the regular public (non RedHat) 2.2.18 kernel does not contain this 
module.
Comment 1 Bill Nottingham 2001-02-28 12:32:54 EST

*** This bug has been marked as a duplicate of 29947 ***

Note You need to log in before you can comment on or make changes to this bug.