Bug 299691 - landscape option on lp/lpr
landscape option on lp/lpr
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: paps (Show other bugs)
5.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Akira TAGOH
QE Internationalization Bugs
RHEL5.2NACK
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-21 00:52 EDT by Norm Murray
Modified: 2013-04-12 15:22 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0286
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 03:52:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch pulled from fedora work (687 bytes, patch)
2007-09-21 00:53 EDT, Norm Murray
no flags Details | Diff
Fixs pap (under cups) landscape bug (412 bytes, patch)
2008-04-04 14:47 EDT, Bob Bugzilla
no flags Details | Diff
cups log for paps-0.6.8-1 (25.80 KB, text/plain)
2008-04-07 11:35 EDT, Bob Bugzilla
no flags Details

  None (edit)
Description Norm Murray 2007-09-21 00:52:08 EDT
Description of problem:
This is because the plain text document is first processed by paps, the UTF-8 to
PostScript converter using Pango, which rotates the document by 90 degrees and
then again processed by CUPS filter pstops that does the same, resulting in a
180 degrees rotation.

The landscape mode should not be applied by paps when invoked as a cups filter
since pstops will take care of that.

The attached patch fixes the issue. As similar fix was committed in Fedora core
7 but it is not mentioned in the ChangeLog (the patch was changed but the file
name of the patch remained unchanged) between paps-0.6.6-17 and paps-0.6.6-18
releases. The Fedora patch is also slightly more intrusive than the attached
patch that just ignores the CUPS option for landscape and just that.
Comment 1 Norm Murray 2007-09-21 00:53:13 EDT
Created attachment 201681 [details]
patch pulled from fedora work
Comment 2 Akira TAGOH 2007-09-24 22:45:06 EDT
Hm, there should be still some issues and not enough with that patch IIRC.
that's why I didn't close an original bug in Fedora I thought. I'll visit this
issue again later.
Comment 3 RHEL Product and Program Management 2007-12-03 15:46:25 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 4 Norm Murray 2007-12-03 19:27:09 EST
Proposing for 5.3 then, but this is a regression from RHEL 4 behavior 
Comment 5 RHEL Product and Program Management 2007-12-03 19:35:43 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 6 Akira TAGOH 2007-12-03 20:26:21 EST
devel_ack. this has been fixed in Fedora recently.

BTW is the blocker flag for 5.3?
Comment 7 Suzanne Yeghiayan 2008-01-28 11:05:05 EST
Yes, since the release flag is rhel-5.3.0 and Keywords Regression is set, the
blocker flag means it is for 5.3.
Comment 9 RHEL Product and Program Management 2008-01-29 14:36:53 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 10 Robin R. Price II 2008-03-11 16:49:11 EDT
As a possible work around to landscape printing:
# enscript --landscape -P printerqueue file_to_print

   -- Robin
Comment 11 Bob Bugzilla 2008-04-04 11:52:46 EDT
I have hit this regression as part of a production system upgrade from RHEL 4.6 
to RHEL 5/5.1. It is causing me a large/critical problem with the customer.

Three points:

  1) I need a work around NOW.  (Please help!)
  2) This should be fixed in RHEL5.1 ASAP.  (or NOW will do).
  3) Can we get the Severity upgraded to Urgent?

Here is my test case:

  date | lp -o landscape

Comment 12 Bob Bugzilla 2008-04-04 12:38:59 EDT
Testing with paps from RHEL5.2 beta yields no success:
  paps-0.6.6-17.el5.i386.rpm - portrait orientation

Testing with paps from FC7 yields no success.
  paps-0.6.6-19.fc7.i386.rpm - blank page
  paps-0.6.8-1.fc7.i386.rpm - job hangs
Comment 13 Bob Bugzilla 2008-04-04 12:53:53 EDT
If someone can build an rpm with the source from RHEL5.2 beta with the above 
attached patch I will test it!
Comment 14 Bob Bugzilla 2008-04-04 14:08:04 EDT
Well, I tried some self service and applied the above attached patch to the 
RHEL5.1 version of paps (paps-0.6.6-17.el5).

It did allow landscape to work.  But, the metrics of the paper are all off.  So 
in my test case the date stamp is printed off the page somewhere in space.  
This makes it look like the page is blank.  Printing enough data shows some 
landscape output, but that is not good enough.  You'll need to fix the paper 
metrics too.

This is really harsh...

Comment 15 Bob Bugzilla 2008-04-04 14:47:47 EDT
Created attachment 301323 [details]
Fixs pap (under cups) landscape bug

My first patch ever!
Comment 16 Akira TAGOH 2008-04-07 05:58:02 EDT
Bob, I'm not sure you have built paps-0.6.8-1.fc7 on rhel5 box before trying
because RHEL5 has inherited FC6. so just installing may not works.

Anyway, 0.6.8-1 works for me. if the issue you saw - i.e. hanging job - 
certainly is caused by paps, it would be appreciated if you can give me any
information like a debugging log from CUPS and a result of what happens if you
run paps manually (invoking /usr/lib/cups/filter/texttopaps manually say) etc.
Comment 17 Bob Bugzilla 2008-04-07 11:35:11 EDT
Created attachment 301532 [details]
cups log for paps-0.6.8-1

Here is the cups log for paps-0.6.8-1.
By hang I mean the job just sits in the queue, not output.
Comment 18 Bob Bugzilla 2008-04-07 11:38:30 EDT
From paps-0.6.8.1

# /usr/lib/cups/filter/texttopaps < text > ps
/usr/lib/cups/filter/texttopaps: error while loading shared libraries: 
libpaps.so.0: cannot open shared object file: No such file or directory
Comment 19 Bob Bugzilla 2008-04-07 12:45:11 EDT
No more 'hangs' with paps-libs installed.

Here is the best work around so far:

rpm -e paps --nodeps
wget ftp://ftp.pbone.net/mirror/download.fedora.redhat.com/pub/fedora/linux/
core/updates/6/i386/paps-0.6.8-1.fc6.i386.rpm
wget ftp://ftp.pbone.net/mirror/download.fedora.redhat.com/pub/fedora/linux/
core/updates/6/i386/paps-libs-0.6.8-1.fc6.i386.rpm
rpm -ivh paps-0.6.8-1.fc6.i386.rpm  paps-libs-0.6.8-1.fc6.i386.rpm

This fixes the landscape bug and some other bugs with margins.

Thank you Akira.
Comment 22 RHEL Product and Program Management 2008-05-09 10:03:32 EDT
This bugzilla was reviewed by QE as a non-FasTrack request.
It has since been proposed for FasTrack. The qa_ack has 
been reset. QE needs to re-review this bugzilla for FasTrack.
Comment 25 Akira TAGOH 2008-05-16 09:23:08 EDT
Fixed in 0.6.6-18.el5.
Comment 29 errata-xmlrpc 2008-06-04 03:52:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0286.html
Comment 32 Bob Bugzilla 2009-01-27 16:24:35 EST
It appears that the page orientation bug (landscape) and page margins bug (page-tp, page-left, etc) continue in RHEL5.3.  Had to back-down to the follow package revisions to get it working again:

paps-0.6.8-1.fc6
paps-libs-0.6.8-1.fc6
cups-1.2.4-11.18.el5_2.3
cups-libs-1.2.4-11.18.el5_2.3
ghostscript-8.15.2-9.1.el5_1.1
Comment 33 Akira TAGOH 2009-01-27 21:13:36 EST
No difference between patches in both version and nothing else patches related to the orientation applied.
Since you've installed packages not shipped in RHEL5, that might breaks something. please make sure once you get rid of them cleanly and install the updated package again.

Note You need to log in before you can comment on or make changes to this bug.