Bug 29993 - Problem with irda on Toshiba Sat. 4280
Summary: Problem with irda on Toshiba Sat. 4280
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-28 10:52 UTC by Inger Karin Haarbye
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-08 15:32:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Inger Karin Haarbye 2001-02-28 10:52:08 UTC
Irda fails on my Toshiba because the newer toshiba-chips (DO) use another
PCI ID than the older ones.

In /usr/src/linux/include/net/irda/toshoboe.h - line 104:

#define PCI_DEVICE_ID_FIR701   0x0701

has to be changed to:

#define PCI_DEVICE_ID_FIR701   0x0d01

before recompiling modules. 
I guess that 0x0701 did work on older toshibas.

Comment 1 Arjan van de Ven 2001-02-28 11:51:50 UTC
This will be fixed in the next kernel we build by having both PCI id's
in the driver.

Comment 2 Arjan van de Ven 2001-02-28 15:24:35 UTC
I'm marking this bug as "fixed in rawhide". If a kernel of version 2.4.2-0.1.17
or newer (once it becomes available) does not work for you, please reopen this
bug.

Comment 3 Inger Karin Haarbye 2001-03-03 22:24:33 UTC
No, I can't get this work with kernel-2.4.2-0.1.19 from rawhide.

In my /etc/modules.conf I have these to lines (for irda):

alias char-major-161 ircomm-tty
alias irda0 toshoboe

If everything workes OK all I have to do is "irattach irda0 -s" to get my Nokia
6210 working (with irda).

This don't work now. "modprobe irda0" gives:

/lib/modules/2.4.2-0.1.19/kernel/drivers/net/irda/toshoboe.o: init_module: No
such device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters
/lib/modules/2.4.2-0.1.19/kernel/drivers/net/irda/toshoboe.o: insmod
/lib/modules/2.4.2-0.1.19/kernel/drivers/net/irda/toshoboe.o failed
/lib/modules/2.4.2-0.1.19/kernel/drivers/net/irda/toshoboe.o: insmod irda0 failed

Anything different I have to do now when both PCI ID's are possible?

Comment 4 Arjan van de Ven 2001-03-05 16:46:45 UTC
The driver in 0.1.19 did have the PCI id in the PCI id table, but later on
it tried to find a device explicitly using the old 2.2 api, and it was missing
the extra ID there. Will be fixed in our next build  (>= 0.1.21).


Comment 5 Arjan van de Ven 2001-03-05 17:30:33 UTC
Since I don't have this hardware, would you be prepared to test a newer kernel
and verify that it works ?

Comment 6 Inger Karin Haarbye 2001-03-05 19:21:09 UTC
Oh yes, I'm waiting... I guess I will soon find a newer kernel in rawhide.

Comment 7 Inger Karin Haarbye 2001-03-08 15:32:09 UTC
Works for me now with kernel-2.4.2-0.1.22 from rawhide.

Comment 8 Arjan van de Ven 2001-03-08 16:45:55 UTC
Thanks for confirming.
"Works for me now" -> closing as fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.