Bug 29995 - Configuration of X on Toshiba 4280 (needs LCD probing)
Summary: Configuration of X on Toshiba 4280 (needs LCD probing)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-28 11:04 UTC by Inger Karin Haarbye
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-27 19:04:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dccprobe from Wolverine installation on Toshiba Satellite 4280 (867 bytes, text/plain)
2001-02-28 18:08 UTC, Inger Karin Haarbye
no flags Details

Description Inger Karin Haarbye 2001-02-28 11:04:29 UTC
A new installation only gives me 800x600 screen on this laptop, even if I
chose 1024x768.

Hor.sync/Vert.fresh was set to 31.5-35.2/50-61 and this is to low.
With HorizSync to 31.5-64.3 and VertRefresh to 50-70 i can get 1024x768 in
16bits color.

Comment 1 Michael Fulbright 2001-02-28 15:12:33 UTC
Which monitor did you choose during configuration?

Comment 2 Inger Karin Haarbye 2001-02-28 16:20:17 UTC
Monitor is autodetected (DDC Probed Monitor) as TOS5082

Comment 3 Brent Fox 2001-02-28 16:34:22 UTC
Can you send the output of ddcprobe?  I'm a little confused, because we usually
can't probe LCD panels.  What happens if you choose Generic LCD 1024x768 display
at the monitor configuration window?

Comment 4 Inger Karin Haarbye 2001-02-28 18:05:53 UTC
ddcprobe seems to work OK for a Toshiba Satellite 2180 I have temporary - and
the display there is detected as TOS5081.

I tried Generic LCD 1024x768 display - seems to work OK for my Toshiba Satellite
4280.

ddcprobe for 4280 as attachment.

Comment 5 Inger Karin Haarbye 2001-02-28 18:08:50 UTC
Created attachment 11382 [details]
dccprobe from Wolverine installation on Toshiba Satellite 4280

Comment 6 Brent Fox 2001-02-28 18:17:55 UTC
Ok, I guess some LCD's can be properly probed.  Cool.  Anyway, it appears that
the problem is that there is no entry in the monitors database to match up with
this monitor.  Since we can grab the monitor EISA ID (TOS5082), we should be
able to look up the sync rates in the monitor database...only there aren't any
entries there that match this EISA ID.  All we have to do is decide on some sync
rates that make sense and I'll add them to the file.

So, do you think that HorizSync=31.5-64.3 and VertRefresh=50-70 sounds good?


Comment 7 Brent Fox 2001-02-28 18:21:33 UTC
Uhh, I have been instructed to defer this to a future release.  It's too late to
add new entries to the monitor database at this time.  But for a current
workaround, I would pick Generic LCD 1024x768 at the monitor screen.



Comment 8 Inger Karin Haarbye 2001-02-28 18:30:59 UTC
I really don't know which HorizSync/VertRefresh are the "right" ones. I got the
idea from a page I found from the "Linux on laptops"-page for almost the same
Toshiba:
http://lisas.de/~david/tsp4270/index.php3

And then I hope this will not do any harm to my display :-)

Comment 9 Brent Fox 2002-01-27 04:36:10 UTC
Ok, I have added the following line to the MonitorsDB file:

Toshiba; Toshiba TOS5082; tos5082; 31.5-48.5; 50.0-70.0; 1

This should allow for the installer to correctly probe for this monitor.  Thanks
for your report.


Note You need to log in before you can comment on or make changes to this bug.