Bug 30008 - Two network cards
Two network cards
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-28 11:48 EST by sandy
Modified: 2014-03-16 22:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 01:35:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sandy 2001-02-28 11:48:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9 i686)


I have two network cards;

desc: "Realtek|RTL-8139"
desc: "Unknown vendor|Generic tulip device"

The unknown is a popular LinkSys LNE100TX ethernet card
that is sold retail at more computer stores.

Anaconda recognized the Realtek and installed the correct
module (8139too) the LinkSys card was not recognized.

Even worse after initial boot Kudzu recognized the
LinkSys and installed the tulip driver and for some
reason uninstalled the 8139too.  It also reconfigured
the eth0 interface and got stuck in an infinite loop
until I broke out.  The uninstall of the 8139too
module caused the DHCP query to fail.  However, upon
rebooting the DHCP query was OK because the 8139too
was re-loaded during the boot.

The /etc/module.conf file is fine;

alias eth0 8139too
alias parport_lowlevel parport_pc
alias sound-slot-0 emu10k1
alias usb-controller usb-uhci
alias eth1 tulip

There is only one interface setup file;

/etc/sysconfig/network-scripts/ifcfg-eth0;

DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes

No setup file for eth1.



Reproducible: Always
Steps to Reproduce:
1.install wolverine with 2 network card - one know the other unknown
2.during 1st boot use kudzu to install and configure second card

	

Actual Results:  Bad setup of first and second card

Expected Results:  both cards should be setup properly
Comment 1 Bill Nottingham 2001-02-28 14:59:03 EST
What happens if you reboot with that configuration; does it work OK?

What happens in this case if you disable hotplug?
Comment 2 sandy 2001-02-28 19:36:51 EST
Please see the bug I described above where kudzu hangs during 
the first boot after the install and fails to configures the network 
card (does put eth1 in /etc/module.conf file but unloads the 8139too 
module and gets stuck in an infinite loop and ultimately fails to 
writes the /etc/sysconfig/network-scripts/ifcfg-eth1 file).

I suspect that anaconda does not complete the total configuration
of the first card (eth0), which isn't totally configured until the 
first boot is completed (this is normal).  But kudzu runs before the 
first card is finished being configured on the first boot and it 
sees only the second card (eth1) is unconfigured and because eth0 is 
not completely setup it gets mixed up as to which card it is really 
trying to configure.

Upon rebooting the DHCP query was OK because the 8139too module was 
re-loaded during the subsequent re-boot.  However, since no 
/etc/sysconfig/network-scripts/ifcfg-eth1 file was made, as I had 
setup during kudzu, the eth1 interface was never configured.

I haven't yet tried to manually configure the LinkSys card (eth1), 
but I expect it will work when I do.
Comment 3 Bill Nottingham 2001-02-28 19:39:24 EST
Do you have what the modules.conf looks like at the first boot before
kudzu runs?
Comment 4 Bill Nottingham 2001-02-28 19:47:36 EST
Where is kudzu hanging (on what screen)?
Comment 5 sandy 2001-03-01 01:35:36 EST
I'm sorry.  The program that went into the infinite loop
is netconfig.  I was fooled because if kudzu finds an 
interface during the boot then netconfig is run 
automatically immediately afterward.

However, netconfig only works with eth0.  Either you
need fix netconfig so that it works with more than one 
interface or not run it automatically during the boot 
after kudzu finds a new interface, because if you
already have one installed netconfig will not work.
Comment 6 Bill Nottingham 2001-03-01 02:16:17 EST
<looks at the code again>

Oooooooops, wow, that's broken in a lot of ways. Will be fixed in
pump-0.8.11 to in general be more sane.
Comment 7 Glen Foster 2001-03-02 12:41:21 EST
We (Red Hat) really need to fix this before next release.

Note You need to log in before you can comment on or make changes to this bug.