Bug 300101 - Choice of network card for installation is broken.
Choice of network card for installation is broken.
Status: CLOSED DUPLICATE of bug 299351
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-21 08:01 EDT by David Woodhouse
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-21 08:35:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2007-09-21 08:01:13 EDT
When I try a network installation I'm offered two network cards -- my internal
Broadcom wireless, and the wired Ethernet device. In that order -- called 'eth0'
and 'eth1'. 

Since we don't have firmware for the bcm43xx in our installer images, I didn't
choose that one -- I chose the wired device.

It didn't work:

11:48:09 INFO    : going to pick interface
11:48:17 INFO    : going to do getNetConfig
11:48:17 INFO    : eth1 is not a wireless adapter
11:48:20 DEBUG   : waiting for link eth1...
11:48:24 DEBUG   :    0 seconds.
11:48:24 DEBUG   : sending anaconda-Linux 2.6.23-0.187.rc6.git7.fc8 ppc as dhcp
vendor-class
11:48:25 DEBUG   : dhcp: ioctl SIOCGIFFLAGS failed: 19 No such device

For kicks I then tried selecting the wireless device... and then it brought up
the wired device (which the kernel seems to be calling 'eth0'), and worked fine. 
(For a whole few seconds until it crashed when I selected 'upgrade' instead of
'install'. qv.)
Comment 1 Joel Andres Granados 2007-09-21 08:35:46 EDT

*** This bug has been marked as a duplicate of 299351 ***

Note You need to log in before you can comment on or make changes to this bug.