Bug 30030 - Anaconda errs during installation of packages
Anaconda errs during installation of packages
Status: CLOSED DUPLICATE of bug 18053
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-02-28 12:20 EST by Mattchu Raimei
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-02-28 18:10:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mattchu Raimei 2001-02-28 12:20:02 EST
Upon starting the installation for the first time, I got through to the 
package installation, whereby it erred.

This was before I checked for the updates disk, so after obtaining and 
placing that .img onto a disk, I tried again. The disk was used when 
indicated, but anaconda wouldn't even start up with this, and erred. It 
repeated this another time, then on the third try, it went okay.

Then it got back to the package installation, and proceeded to hang again, 
with this output:

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
  File "/tmp/updates/todo.py", line 1491, in doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "/tmp/updates/fstab.py", line 705, in mountFilesystems
    isys.losetup("/tmp/loop1", "/mnt/loophost/redhat.img")
  File "/usr/lib/anaconda/isys.py", line 46, in losetup
    targ = os.open(file, mode)
OSError: [Errno 2] No such file or directory: '/mnt/loophost/redhat.img'

Local variables in innermost frame:
file: /mnt/loophost/redhat.img
mode: 2
readonly: 0
device: /tmp/loop1

ToDo object:


I tried another two times, both with and without updates disk. Both times 
led to the same error, as above.

I'm running the installation on an Intel Celeron 400mHz, it's to be set up 
as dual-boot (RedHat 7.0 and Win98), with a partitionless install.

Ctrl+Alt+F4 showed a message about EXT2.
Ctrl+Alt+F3 showed 'Autopartitioning failed' and it reported being unable 
to produce /boot, /, or /Swapfile-000 because of lack of space.
[I don't think the third named partition is called that; I'm relying on 
memory here, I'm unsure of what it is..]

The partitioning screen that appears during install also reported that my 
Windows partition had no free space, even though there is 1.35GB left on 
the drive according to Win98.
Comment 1 Michael Fulbright 2001-02-28 18:06:29 EST
Are you putting the '/' mount point on the same partition as you are doing the
hard drive install from?
Comment 2 Mattchu Raimei 2001-02-28 18:10:30 EST
I am doing, yes.. I only have the one drive/partition, so I'm sure of that..
Comment 3 Michael Fulbright 2001-03-01 14:02:20 EST
This is not supported in 7.0.

You might want to look at bug 18053.

*** This bug has been marked as a duplicate of 18053 ***

Note You need to log in before you can comment on or make changes to this bug.