Bug 300401 - Obsolescent xscreensaver entry in GNOME menus
Obsolescent xscreensaver entry in GNOME menus
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-21 10:24 EDT by Joachim Frieben
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-21 12:00:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2007-09-21 10:24:41 EDT
Description of problem:
After installing "xscreensaver-*" packages in addition to
"gnome-screensaver", there are now screensaver entries in
"System > Preferences > Look and Feel"

Version-Release number of selected component (if applicable):
xscreensaver-5.03-7.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Install "xscreensaver-*" packages on a current "rawhide" system.
2. Open "System > Preferences > Look and Feel"
  
Actual results:
Two "screensaver" entries are present, one for "gnome-screensaver",
the second one for "xscreensaver".

Expected results:
"xscreensaver" shouldn't have its own menu label.

Additional info:
Correct behaviour in "F7" and earlier.
Comment 1 Mamoru TASAKA 2007-09-21 11:07:24 EDT
Well, actually I don't use gnome-screensaver and so I don't care
about gnome-screensaver. However I guess 
gnome-screensaver-hide-xscreensaver.menu should be updated?
(I am not familiar with gnome-panel)...

Current gnome-screensaver-properties.desktop (in xscreensaver-base) is:
-----------------------------------------------
[Desktop Entry]
Exec=xscreensaver-demo
Icon=xscreensaver.xpm
Terminal=false
Name=Screensaver
Name[da]=Pauseskærm
......
Name[zh_TW]=螢幕保護程式
Comment=Change screensaver properties
Comment[da]=Ændr egenskaber for pauseskærm
Comment[fi]=Muuta näytönsäästäjän ominaisuuksia
Comment[fr]=Modifier les propriétés de l'économiseur d'écran
Comment[hu]=Képernyővédő tulajdonságainak megváltoztatása
Comment[nl]=Verander schermbeveiliging voorkeuren
Type=Application
Categories=Settings;DesktopSettings;
X-Desktop-File-Install-Version=0.13
OnlyShowIn=GNOME;
----------------------------------------------------

Matthias, help?
Comment 2 Ray Strode [halfline] 2007-09-21 12:00:34 EDT
should be fixed in tomorrow's rawhide.

It's because we moved the "Settings;DesktopSettings;" items to Look and Feel,
and didn't account for that in the menu file (as Mamoru suspected)

Note You need to log in before you can comment on or make changes to this bug.