Bug 30073 - vim is missing important features (like :split and visual mode)
vim is missing important features (like :split and visual mode)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-28 15:00 EST by keithu@parl.clemson.edu
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-28 15:00:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description keithu@parl.clemson.edu 2001-02-28 15:00:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22smp i686)


Ok, it looks like you guys are including a developer release of Vim.  Um,
breaking the editor is fairly unacceptable.  Great features like window
splitting (:split) and visual mode (ctrl-v and shift-v) just plain don't
seem to work.  Will these things be fixed by the release?  

Reproducible: Always
Steps to Reproduce:
1. start vi
2. type ":split"
3.	
	

Actual Results:  I get the message: "Sorry, this command is not
implemented"

Expected Results:  I should get a split window.
Comment 1 Bernhard Rosenkraenzer 2001-02-28 15:14:05 EST
:split and friends are not features of the standard vi, therefore they aren't 
in vim-minimal.
Use vim-enhanced and they'll do just what you expect.

A very useful command is "alias vi=vim"

Comment 2 keithu@parl.clemson.edu 2001-02-28 15:24:55 EST
Ack!  You've got to be kidding!  Why the change?  Under RH7.0, /bin/vi is a
nice, tiny editor (360K) that includes features like :split and friends.  Now, I
have to use that mammoth /usr/bin/vim at a whopping 1.8M or something
ridiculous?  <sigh>  Not to mention having to remember to install it (apparently
wasn't installed by default on the install I did).  Frankly, that sucks.

Note You need to log in before you can comment on or make changes to this bug.