Bug 300881 - segfault with sample program (and others)
segfault with sample program (and others)
Status: CLOSED DUPLICATE of bug 205499
Product: Fedora
Classification: Fedora
Component: gnome-python2-extras (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-21 13:54 EDT by Colin Walters
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 22:41:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb session (5.54 KB, text/plain)
2007-09-21 13:54 EDT, Colin Walters
no flags Details

  None (edit)
Description Colin Walters 2007-09-21 13:54:40 EDT
Description of problem:

Using the sample program from gnome-python2-gtkmozembed causes a segfault inside
Mozilla.

Version-Release number of selected component (if applicable):
gnome-python2-gtkmozembed-2.14.3-4.fc7

How reproducible:
Every time

Steps to Reproduce:
1. Copy example program from
file:///usr/share/gtk-doc/html/pygtkmozembed/class-gtkmozembed.html into a file
2. Execute file
  
Actual results:
segfault

Expected results:
browser

Additional info:

This is also reproducible on current Rawhide.
Comment 1 Colin Walters 2007-09-21 13:54:40 EDT
Created attachment 202651 [details]
gdb session
Comment 2 Matthew Barnes 2007-10-02 22:35:36 EDT
Confirmed; NULL pointer dereference.

EmbedPrivate::Realize (this=0x9e122f0, aAlreadyRealized=0xbfa93e68)
    at EmbedPrivate.cpp:257

(gdb) l
252
253       // Create our session history object and tell the navigation object
254       // to use it.  We need to do this before we create the web browser
255       // window.
256       mSessionHistory = do_CreateInstance(NS_SHISTORY_CONTRACTID);
257       mNavigation->SetSessionHistory(mSessionHistory);
258
259       // create the window
260       mWindow->CreateWindow();
261
(gdb) p mNavigation
$1 = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
Comment 3 Matthew Barnes 2007-10-02 22:41:27 EDT

*** This bug has been marked as a duplicate of 205499 ***

Note You need to log in before you can comment on or make changes to this bug.