Bug 300991 - Moving the "Open File" menu window crashes display
Moving the "Open File" menu window crashes display
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Norm Murray
Fedora Extras Quality Assurance
:
Depends On:
Blocks: c->xlib.lock
  Show dependency treegraph
 
Reported: 2007-09-21 14:40 EDT by Horst H. von Brand
Modified: 2008-01-31 17:24 EST (History)
1 user (show)

See Also:
Fixed In Version: -6.3.5.9-1.fc8.i386
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-31 17:24:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Core from display for ImageMagick-6.3.5.9-1.fc8 (6.72 MB, application/octet-stream)
2007-10-01 08:55 EDT, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2007-09-21 14:40:12 EDT
Description of problem:


Version-Release number of selected component (if applicable):
ImageMagick-6.3.2.9-3.fc7

How reproducible:
Always

Steps to Reproduce:
1. Run "display" from a terminal window
2. Move the "Open File" window
3.
  
Actual results:
display: xcb_xlib.c:41: xcb_xlib_lock: Assertion `!c->xlib.lock' failed.
Aborted

Expected results:
Not the above ;-)

Additional info:
Comment 1 Norm Murray 2007-09-23 19:59:28 EDT
Please retest with ImageMagick-6.3.5.9-1.fc8 which should be in the repos now as
I can't reproduce on that. 
Comment 2 Horst H. von Brand 2007-09-24 10:56:36 EDT
Just tried again (after updating ImageMagick to 6.3.5.9-1.fc8 and a lot of other
stuff). Still the same.
Anything else that could be involved here?
Comment 3 Norm Murray 2007-09-25 23:16:53 EDT
Could be a deeper issue in X, 

Can you get a core, or install debuginfo packages and reproduce under gdb to get
a backtrace? 
Comment 4 Horst H. von Brand 2007-10-01 08:55:22 EDT
Created attachment 212261 [details]
Core from display for ImageMagick-6.3.5.9-1.fc8

Core file from ImageMagick, rawhide i686 (dual core) up to date as of today.
Comment 5 Horst H. von Brand 2008-01-02 14:17:05 EST
Now fixed. Seems to have been an X issue (ImageMagick hasn't changed since).
Comment 6 Horst H. von Brand 2008-01-10 12:33:44 EST
Close this one? Hasn't shown up for a while, and wasn't ImageMagick's fault in
any case.

Note You need to log in before you can comment on or make changes to this bug.