Bug 30115 - eepro100 driver is buggy kernel 2.2.17-4
eepro100 driver is buggy kernel 2.2.17-4
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-02-28 19:18 EST by Peter Mardahl
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-03-05 21:38:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Peter Mardahl 2001-02-28 19:18:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2 alpha)

Hello,  the eepro100 driver seems to be buggy in 2.2.17-4.   I installed
2.4.2 and it seems to have fixed the problem.  Here are the symptoms:
(check comp.os.linux.alpha for the same thing unmunged by this submission

Feb 28 16:07:16 raman kernel: <sc 0(84,1f4,11ffff810)><sc
c 0(17,1f4,11ffff810)><sc 53(8,1f4,11ffff810)><4>eth0: Transmit timed out:
s 0050  0c00 at 473086/473114 command 000c0000.
Feb 28 16:07:56 raman kernel: eth0: Transmit timed out: status 0050  0c00
at 473
220/473248 command 000c0000.

Which leads to a /proc/net/dev like this:

Inter-|   Receive                                                | 
 face |bytes    packets errs drop fifo frame compressed multicast|bytes   
ts errs drop fifo colls carrier compressed
    lo:       0       0    0    0    0     0          0         0       
 0    0    0    0     0       0          0
  eth0:57684311  494985    0    0    0     0          0         0 46668024 
90  112    0   36  1684       3          0

I've tried forcing both full and half-duplex with no effect on the errors.
I've also tried another machine on the ethernet connection:  it seems to
be fine.

Reproducible: Always
Steps to Reproduce:
1.  Get a Compaq DS20E and put an eepro100 in it.  Install RedHat 7.0
2.  Boot the stock 2.2.17-4smp kernel, and connect the card to a 100MHz hub
     another 100MHz ethernet card.
3.  Start sending lots of traffic back and forth.  There will be errors.	

Actual Results:  Net performance was pretty bad because many packets were

Expected Results:  Collisions are expected, but not fifo, frame, and other
Comment 1 Peter Mardahl 2001-03-05 21:38:29 EST

  I reported this bug in the first place.  I have added information:
the bug is NOT fixed by using kernel 2.4.2.

Instead, it simply becomes far less frequent.
Comment 2 Phil Copeland 2001-06-04 14:49:57 EDT
New fixes added to kernel

Wait for the next release (7.1)

Note You need to log in before you can comment on or make changes to this bug.