Bug 30116 - ReiserFS not available during install
ReiserFS not available during install
Status: CLOSED DUPLICATE of bug 27610
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2001-02-28 19:39 EST by John Fogelvik
Modified: 2007-03-26 23:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-04-11 16:12:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description John Fogelvik 2001-02-28 19:39:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

I was trying to install woverine, and expected to have the choice of using 
ReiserFS by now.
However the choice to format as ReiserFS is not available anywhere during 
install (neither when using "Disk Druid" or after fdisk).

I was so surprised at this so I switched to the commandline to looked 
around, and sure enough: the reiserfs-utils are in the install-system, but 
not being used!

Now I really wanted to get this to work, so I actually ran mkreiserfs by 
hand on my "/usr"-partition (and did not let anaconda do it) hoping that 
it would get used if it existed, but...
...I tried to look for any traces of ReiserFS-support in the install-
system-kernel, but could not find that anywhere.
Not during the bootup messages, and not by doing a insmod/depmod/lsmod.

I then tried to untar the /modules/modules.cgz file in the anaconda-
runtime system, but there was not enough writeable space to both copy the 
file off the CD and then untar it, so... ...no go!

As you might have figured by now ReiserFS support is a big issue for me, 
and so is it for everyone else in my peer-group that has seen the 
performance of that filesystem.
I have been migrating 3 RedHat-7.0 systems to ReiserFS by hand now, and 
really don't feel like having to do it all over again for RedHat-7.0 (I 
hear S.u.S.E has ReiserFS as an option during install... ;->).

I have not tested that yet, but there seems to be someone (Miguel Freitas) 
who has created ReiserFS-enabled RedHat-7.0 CDs allready 
(http://cambuca.ldhs.cetuc.puc-rio.br/),so implementing this should not be 
that hard.

RedHat /needs/ to include a log-based filesystem in the install now, too 
many other distributions allready have done so 
(http://www.ibiblio.org/JBLinux/ for example).

I am flaging the "Severity" as "Enhancment", since this is a "new feature" 
at the moment, but I certainly consider this a bug, and a quite major one 

Reproducible: Always
Steps to Reproduce:
1. Start installation.
2. Try to get ReiserFS in the installation process.
3. Fail!   ;-)

Actual Results:  No success (see description).

Expected Results:  I expected this to work allready...

Installation is done on my scsi-disk (sda).
Partitioed as following:
/      500MB       EXT2
<SWAP> 120MB       Linux Swap
/usr   34GB        (Trying to get ReiserFS here)
Comment 1 Michael Fulbright 2001-02-28 22:24:59 EST
This is something we will consider for future releases.
Comment 2 Michael Fulbright 2001-04-11 16:12:58 EDT

*** This bug has been marked as a duplicate of 27610 ***

Note You need to log in before you can comment on or make changes to this bug.