Bug 301181 - Probelm build from src.rpm as non root
Probelm build from src.rpm as non root
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mod_auth_kerb (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-21 16:06 EDT by Simo Sorce
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 07:48:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simo Sorce 2007-09-21 16:06:41 EDT
Description of problem:
The spec file contains an error, it lists --with-apxs=/usr instead of
--with-apache=/usr

This cause a build as user using a command like this:
rpmbuild --define "_topdir /my/own/rpmbuild/tree" -ba mod_auth_kerb.spec
to fail.
The reason it works normally is that when built as root '/usr/sbin' is in the
path so the configure finds it. When building as user '/usr/sbin' is not in the
path by default and configure fails to find apxs

Version-Release number of selected component (if applicable):
5.3-*

Additional info:

The fix is simple, use --with-apache=/usr and not --with-apxs=/usr (--with-apxs
is something unknown to the configure.in file).
Comment 1 Joe Orton 2007-09-25 07:48:11 EDT
Fixed in Raw Hide, thanks for the report.

http://koji.fedoraproject.org/koji/taskinfo?taskID=174123

Note You need to log in before you can comment on or make changes to this bug.