Bug 30151 - bullets/paragraph dialog crash in 0.7.13
bullets/paragraph dialog crash in 0.7.13
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: abiword (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-01 00:27 EST by Jeremy Katz
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 00:27:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2001-03-01 00:27:23 EST
Note that this bug is also filed in the abiword bugzilla at
http://www.abisource.com/bugzilla/show_bug.cgi?id=1183, but I'm filing it
here also so that if there's an easy upstream fix, it can be applied to the
Red Hat package to avoid other people having the same problem (since it's a
_really_ easy crash to trigger)

In the bullets/numbering dialog of AbiWord 0.7.13, if you hit apply without

changing anything, you get a segfault.  gdb backtrace is:



Debugging information:

(no debugging symbols found)...0x40768fb9 in __wait4 () from /lib/libc.so.6

#0  0x40768fb9 in __wait4 () from /lib/libc.so.6

#1  0x407d6d0c in __DTOR_END__ () from /lib/libc.so.6

#2  0x403527b8 in gnome_segv_handle () from /usr/lib/libgnomeui.so.32

#3  <signal handler called>
#4  0x081778c2 in UT_HashTable::hashFunc () at eval.c:41

#5  0x081776dd in UT_HashTable::findEntry () at eval.c:41

#6  0x0810576a in pt_PieceTable::getStyle () at eval.c:41

#7  0x08100306 in PP_lookupProperty () at eval.c:41

#8  0x08100432 in PP_evalProperty () at eval.c:41

#9  0x080e4e7a in fl_BlockLayout::getProperty () at eval.c:41

#10 0x080e399e in fl_BlockLayout::_lookupProperties () at eval.c:41

#11 0x080e8106 in fl_BlockLayout::doclistener_changeStrux () at eval.c:41

#12 0x080ed518 in fl_DocListener::change () at eval.c:41

#13 0x080fd616 in PD_Document::notifyListeners () at eval.c:41

#14 0x08101ba2 in pt_PieceTable::_fmtChangeStruxWithNotify () at eval.c:41#15

0x08101c8c in

changeStruxFmt__13pt_PieceTable12_PTChangeFmtUiUiPPCcT412_PTStruxType () at

eval.c:41

#16 0x080e9f90 in fl_BlockLayout::StartList () at eval.c:41

#17 0x0813b790 in AP_Dialog_Lists::Apply () at eval.c:41

#18 0x400ef361 in gtk_marshal_NONE__NONE () from /usr/lib/libgtk-1.2.so.0

#19 0x40121a86 in gtk_handlers_run () from /usr/lib/libgtk-1.2.so.0

#20 0x40120dbd in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0

#21 0x4011eb75 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0

#22 0x40087c3d in gtk_button_clicked () from /usr/lib/libgtk-1.2.so.0

#23 0x400893fd in gtk_real_button_released () from /usr/lib/libgtk-1.2.so.0

#24 0x400ef361 in gtk_marshal_NONE__NONE () from /usr/lib/libgtk-1.2.so.0

#25 0x40120c41 in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0

#26 0x4011eb75 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0

#27 0x40087b6d in gtk_button_released () from /usr/lib/libgtk-1.2.so.0

#28 0x40088ce7 in gtk_button_button_release () from /usr/lib/libgtk-1.2.so.0

#29 0x400ef06c in gtk_marshal_BOOL__POINTER () from /usr/lib/libgtk-1.2.so.0

#30 0x40120dfd in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0

#31 0x4011eb75 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0

#32 0x40158dc9 in gtk_widget_event () from /usr/lib/libgtk-1.2.so.0

#33 0x400eefe5 in gtk_propagate_event () from /usr/lib/libgtk-1.2.so.0

#34 0x400ee0bf in gtk_main_do_event () from /usr/lib/libgtk-1.2.so.0

#35 0x401a3b7f in gdk_event_dispatch () from /usr/lib/libgdk-1.2.so.0

#36#37 0x401d6f38 in g_main_iterate () from /usr/lib/libglib-1.2.so.0

#38 0x401d70fc in g_main_run () from /usr/lib/libglib-1.2.so.0

#39 0x400ed983 in gtk_main () from /usr/lib/libgtk-1.2.so.0

#40 0x080aca02 in AP_UnixGnomeApp::main () at eval.c:41

#41 0x080ac788 in main () at eval.c:41

#42 0x406cd091 in __libc_start_main (main=0x80ac770 <main>, argc=1,

    ubp_av=0xbffff7bc, init=0x80a9fe8 <_init>, fini=0x81f7740 <_fini>,

    rtld_fini=0x4000e374 <_dl_fini>, stack_end=0xbffff7ac)

    at ../sysdeps/generic/libc-start.c:129 0x401d68f3 in g_main_dispatch ()
from /usr/lib/libglib-1.2.so.0
Comment 1 Owen Taylor 2001-07-21 18:44:48 EDT
Seems to be fixed in 0.7.14.

Note You need to log in before you can comment on or make changes to this bug.