Bug 30152 - installer didn't find Tulip board
installer didn't find Tulip board
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-01 00:40 EST by Daniel Senie
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-04 18:22:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Senie 2001-03-01 00:40:22 EST
Installation of Wolverine didn't recognize a Kingston KNE100TX (real DEC 
Tulip chip)
Comment 1 Bill Nottingham 2001-03-01 00:47:34 EST
lspci -n output?
Comment 2 Daniel Senie 2001-03-01 01:15:03 EST
More info: I was able to manually add the:

alias eth0 tulip

and the various stuff under /etc/sysconfig

and get the board working just fine. There's no trouble with the card, or with 
the kernel once installed, just with the installer. This same system with a 
RedHat 6.2 installation finds the card without problem.

Here's the lspci -n output if it helps:

00:00.0 Class 0600: 8086:7190 (rev 03)
00:01.0 Class 0604: 8086:7191 (rev 03)
00:07.0 Class 0601: 8086:7110 (rev 02)
00:07.1 Class 0101: 8086:7111 (rev 01)
00:07.2 Class 0c03: 8086:7112 (rev 01)
00:07.3 Class 0680: 8086:7113 (rev 02)
00:0c.0 Class 0401: 1073:000a (rev 04)
00:0e.0 Class 0400: 109e:0350 (rev 12)
00:0f.0 Class 0200: 11ad:0002 (rev 21)
01:00.0 Class 0300: 1002:5246
Comment 3 Bill Nottingham 2001-03-01 01:18:15 EST
OK, I'm confused. This is in the pci mappings, and has been there
forever.
Comment 4 Daniel Senie 2001-03-01 01:34:15 EST
I agree with you! This is why I reported the problem. In all the years I've 
been using this particular Tulip card, I've never seen the installer fail to 
notice its presence. Something in the anaconda with Wolverine missed it...
Comment 5 Michael Fulbright 2001-03-01 12:37:28 EST
One VC3 what kind of output do you get with 'suggestion' in the line as you are
going throught the first part of the installer. Try doing a text mode install,
makes it easier to switch VCs.
Comment 6 Michael Fulbright 2001-03-01 17:46:41 EST
You changed 30152 to NEEDSINFO. I'd like to do my best to provide you
with that. What I need to understand is exactly what you are asking me
to do.

I always do the installs using text mode, so switching to VC3 is no
problem.

I didn't know how to parse the sentence in your bug update that said:

"One VC3 what kind of output do you get with 'suggestion' in the line as
you are going through the first part of the installer."

I'm not sure it's a sentence, and I'm not sure I understand what you are
asking. Could you rephrase that and I'll go try the installation again?

Thanks,

Dan
Comment 7 Michael Fulbright 2001-03-01 17:57:03 EST
No problem - what I am asking is that you check on vc3 after every screen you go
through in the earliest stages of the install to see if there is any output with
the word 'suggestion' in it. These lines indicate that the installer has found a
device and is installing a device driver for it. I'm wondering if the tulip is
not being detected.
Comment 8 Daniel Senie 2001-03-01 18:11:10 EST
Just reloaded the machine and watched VC3. Saw the 'suggestion' things you were 
talking about. It showed them for agpgart and usb-uhci, but none for the tulip.

Let me know if there's anything else I can do to help diagnose this. If you 
want to build a new loader for me to try, I'm quite willing (simplest would be 
to build a new ISO image of disc1, which I'd download, burn and test).
Comment 9 Michael Fulbright 2001-03-02 11:20:24 EST
First - you are using a bootnet.img floppy image, or booting from CD, right?

Second - once you get into the second stage of the installer (you'll know
because there is a bash prompt on VC2), try this:

python
from kudzu import *
print probe(CLASS_NETWORK, BUS_UNSPEC, PROBE_ALL)

and let us know what you see.
Comment 10 Daniel Senie 2001-03-02 11:41:29 EST
I am booting from the CD. No problem getting into the VC2 and getting the info.

First, an apology... the card in this machine wasn't the one I thought it was. 
It's a Netgear card, not the Kingston KNE100TX I have so many of, and thought 
was in it. It does operate with the Tulip driver, though, just fine.

Output you wanted said:

Driver:  Lite-on|LNE100TX
Driver:  disabled
Driver:  eth

or something close to that. I don't have a way to cut/paste from the machine at 
that state of booting.

I suspect the chip on this card is one of the PNIC ones (tulip compatible).

Dan
Comment 11 Bill Nottingham 2001-03-02 12:10:21 EST
OK, can you post the 'lspci -v' output? It appears that the installer
is thinking your card doesn't have an IRQ, so it must be disabled.
Comment 12 Daniel Senie 2001-03-04 18:22:15 EST
Here's the lspci output relating to the Ethernet card. Please note that I'm 
transcribing this, not cut/paste, so this might not be 100% perfect:

00:0f.00 Ethernet Controller: Lite-On Communications, Inc. LNE-100TX (rev21)
Subsystem: Netgear FA310TX
flags: busmaster, medium devsel, latency 64, IRQ 10
I/O Ports at 1400 [disabled][size=256]
Memory at f0008000 (32-bit, non-prefetchable)[disabled][size=256]
Expansion ROM at <unassigned>[disabled][size=256K]

I think I caught all of it. Please let me know what else you need.


Comment 13 Bill Nottingham 2001-03-05 00:44:34 EST
Hm, ok, if the device has an IRQ, it's not disabled, even if all its other
resources are.

Will be fixed in kudzu-0.97.5-1.

Note You need to log in before you can comment on or make changes to this bug.