Bug 301661 - yum pulling in 386 packages
yum pulling in 386 packages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-09-22 11:02 EDT by Steve Grubb
Modified: 2014-01-21 17:59 EST (History)
4 users (show)

See Also:
Fixed In Version: 3.2.7-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 03:15:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
results from "yum -d 6 update" (84.84 KB, text/plain)
2007-09-22 11:02 EDT, Steve Grubb
no flags Details
output from "yum list installed" (99.77 KB, text/plain)
2007-09-22 17:06 EDT, Steve Grubb
no flags Details

  None (edit)
Description Steve Grubb 2007-09-22 11:02:54 EDT
Description of problem:
My machine has no 386 packages installed. When I type "yum update"
NetworkManager seems to be picked up as both 32 & 64 bit package and pulled in
i386 packages and all their dependencies. Typing "yum update NetworkManager"
resolves correctly and pulls in only x86_64 packages.

Today's update of NetworkManager deletes dhcdbd. If that package is deleted,
then "yum update" works fine - only 64 bit packages are selected. But when it
has to do the delete, 386 packages get pulled in.

Version-Release number of selected component (if applicable):
yum-3.2.5-3.fc8

How reproducible:
always

Steps to Reproduce:
1. make sure no i386 packages installed on x86_64
2. yum update
  
Actual results:
pulls in i386 packages

Expected results:
only 64 bit packages

Additional info:
will attach some debug info.
Comment 1 Steve Grubb 2007-09-22 11:02:54 EDT
Created attachment 203071 [details]
results from "yum -d 6 update"
Comment 2 Seth Vidal 2007-09-22 15:07:46 EDT
if you could - please output: yum list installed

Comment 3 Steve Grubb 2007-09-22 17:06:24 EDT
Created attachment 203211 [details]
output from "yum list installed"
Comment 4 Jeremy Katz 2007-10-09 17:09:45 EDT
Preliminary patch for this sent to yum-devel...
Comment 5 Jeremy Katz 2007-10-10 11:51:21 EDT
Fixed in 3.2.6-3 and upstream
Comment 6 Fedora Update System 2007-10-15 17:24:28 EDT
yum-3.2.7-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum'
Comment 7 Michal Jaegermann 2007-10-18 13:33:53 EDT
> yum-3.2.7-1.fc7 has been pushed to the Fedora 7 testing repository

Ahem! This is with yum-3.2.7-1.fc8 on a rawhide installation with no
i?86 packages installed.  On an attempt to run today updates:

 libgssglue              x86_64     0.1-4.fc8        development        22 k
     replacing  libgssapi.x86_64 0.11-2.fc8
 libgssglue              i386       0.1-4.fc8        development        21 k
     replacing  libgssapi.x86_64 0.11-2.fc8

This looks exactly as before.
Comment 8 Fedora Update System 2007-10-24 03:15:33 EDT
yum-3.2.7-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Michal Jaegermann 2007-10-24 10:39:30 EDT
Does yum-3.2.7-1.fc7 really differs that much from yum-3.2.7-1.fc8?

Comment #7 reported what happened with the later and despite of
"please make note of it in this bug report" was apparently not taken
into account and the bug was closed with 3.2.7-1.fc7.
Comment 10 Michal Jaegermann 2007-12-03 17:13:52 EST
Just a note that this is what I got with yum-3.2.7-2.fc9 from rawhide:

 kdelibs3                x86_64     3.5.8-16.fc9     development        17 M
     replacing  kdelibs.x86_64 6:3.5.8-7.fc8

 kdelibs3                i386       3.5.8-16.fc9     development        17 M
     replacing  kdelibs.x86_64 6:3.5.8-7.fc8

i.e kdelibs3.i386 "replacing" kdelibs.x86_64.  Plus around 40 Megs of
other i386 stuff pulled in due to kdelibs3.i386 dependencies.

Looks to me like a clear candidate for "REOPEN".  Opinions?
Comment 11 Seth Vidal 2007-12-03 17:21:32 EST
I just built 3.2.8 for f7 and f8 - give that a try first, please.

Note You need to log in before you can comment on or make changes to this bug.