Bug 30169 - Xserver, Xterminal. RedHat 7.0
Xserver, Xterminal. RedHat 7.0
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-01 09:22 EST by Need Real Name
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 09:22:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-01 09:22:27 EST
Hi!

I am trying to turn my RH7.0 machine into a X terminal and a Xserver (for
other X terminal in the house). The name of the machine being lorient.
I use kdm (KDE 2.1 beta 2) and I modified

inittab:

...

# Run xdm in runlevel 5
# xdm is now a separate service
x1:5:respawn:/etc/X11/prefdm -nodaemon
x2:5:respawn:/usr/X11R6/bin/X -indirect lorient


Xaccess:

...

# match, for Direct and Broadcast Query messages, only entries without
# right hand sides can match.
#

*					#any host can get a login window

#
# To hardwire a specific terminal to a specific host, you can
# leave the terminal sending indirect queries to this host, and

# so this may not work in all environments.
#

...

*		CHOOSER BROADCAST	#any indirect host can get a chooser

#
# If you'd prefer to configure the set of hosts each terminal sees,
# then just uncomment these lines (and comment the CHOOSER line above)

...


Xservers:

...

# you can add them here as well.  Each X terminal line should
# look like:
#	XTerminalName:0 foreign
#
#:0 local /usr/X11R6/bin/X 


and xdm-config


! SECURITY: do not listen for XDMCP or Chooser requests
! Comment out this line if you want to manage X terminals with xdm
DisplayManager.requestPort:	1



Here are my problems:
I get the window listing all the machines on house but I cannot connect to
any of them. It looks like they refuse the connection.
My machine does not appear on the list, I cannot access it via an Xterminal
or something.


Could you please tell me what i did wrong.


Thanks in advance for any help


		Daniel
Comment 1 Mike A. Harris 2001-03-01 16:13:56 EST
Sorry, I do not see a bug here. Please try the Red Hat 7.0 mailing list
(guinness) for help setting up XFree86.  Bugzilla's for bugs.
Comment 2 Need Real Name 2001-03-02 03:21:25 EST
I considered that as a bug because on RedHat 6.2 it was working! So, I was just
wondering if some parameters had been modified in XFree (especially in xdm and
the XDMCP configuration) that would make the changes I mentionned uncomplete
now.

Daniel
Comment 3 Need Real Name 2001-03-07 09:41:40 EST
Hi!


Now I just want to have the XDMCP broadcasting available again. I will study the
problem of the XDMCP query later on.


What has changed in term of security between the RedHat 6 serie (at least 6.1
and 6.2) and the redhat 7.0 serie? Is the XDMCP broadcasting disabled? Then how
is it disabled and how can it be put set again?

I looked in many different mailing list without success. This is a very common
question, many people have had troubles with that but no one came with a clean
and satisfactory answer, to my opinion. The info I get are more quick and ugly
hacks than nothing else!
Many people play with gdm.conf but I DO NOT use gdm. I just want my machine back
on the list. What and where is the parameter that has changed between the two
versions. Why is this not documented? (a remark in the file for instance..)

I suspect it has something to do with /etc/X11/xdm/xdm-config (port?
availability? Pam?...) I do not succeed to get the broadcasting back and I need
it now! 


I thank you for your help.


Daniel

Note You need to log in before you can comment on or make changes to this bug.