Bug 301721 - Pulseaudio hangs on startup
Pulseaudio hangs on startup
Status: CLOSED DUPLICATE of bug 284171
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-22 12:12 EDT by Hal Duston
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-23 20:16:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace generated by attaching gdb to hung pulseaudio process (9.49 KB, text/plain)
2007-09-22 12:12 EDT, Hal Duston
no flags Details
strace of pulseaudio process (1/4) (11.12 KB, text/plain)
2007-09-22 12:15 EDT, Hal Duston
no flags Details
strace of pulseaudio process (2/4) (217.93 KB, text/plain)
2007-09-22 12:16 EDT, Hal Duston
no flags Details
strace of pulseaudio process (3/4) (222.25 KB, text/plain)
2007-09-22 12:16 EDT, Hal Duston
no flags Details
strace of pulseaudio process (4/4) (603 bytes, text/plain)
2007-09-22 12:17 EDT, Hal Duston
no flags Details

  None (edit)
Description Hal Duston 2007-09-22 12:12:27 EDT
Description of problem: 
pulseaudio hangs on startup.

Version-Release number of selected component (if applicable):
akode-pulseaudio-2.0.1-8.fc8
alsa-plugins-pulseaudio-1.0.14-2.fc8
pulseaudio-module-x11-0.9.7-0.11.svn20070907.fc8
pulseaudio-lib-zeroconf-0.9.7-0.11.svn20070907.fc8
pulseaudio-debuginfo-0.9.7-0.11.svn20070907.fc8
pulseaudio-module-lirc-0.9.7-0.11.svn20070907.fc8
pulseaudio-lib-0.9.7-0.11.svn20070907.fc8
pulseaudio-utils-0.9.7-0.11.svn20070907.fc8
pulseaudio-0.9.7-0.11.svn20070907.fc8
audacious-plugins-pulseaudio-1.3.5-2.fc8
pulseaudio-lib-glib2-0.9.7-0.11.svn20070907.fc8
pulseaudio-module-zeroconf-0.9.7-0.11.svn20070907.fc8
pulseaudio-esound-compat-0.9.7-0.11.svn20070907.fc8
pulseaudio-module-gconf-0.9.7-0.11.svn20070907.fc8
How reproducible:
90%

Steps to Reproduce:
1.Log in using gnome
2.Launch terminal
3.pactl list
  
Actual results:
Connection failure: Connection refused

Expected results:
Sound module module

Additional info:
 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio
Controller (rev 02)
snd_hda_intel          30817  1
snd_hda_codec         264897  1 snd_hda_intel
snd_seq_dummy          12613  0
snd_seq_oss            40897  0
snd_seq_midi_event     16577  1 snd_seq_oss
snd_seq                63201  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         17109  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            53217  0
snd_mixer_oss          25537  1 snd_pcm_oss
snd_pcm                93129  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_timer              32585  2 snd_seq,snd_pcm
snd                    71785  11
snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              17249  1 snd
snd_page_alloc         18897  2 snd_hda_intel,snd_pcm
Comment 1 Hal Duston 2007-09-22 12:12:27 EDT
Created attachment 203101 [details]
Backtrace generated by attaching gdb to hung pulseaudio process
Comment 2 Hal Duston 2007-09-22 12:15:01 EDT
Created attachment 203111 [details]
strace of pulseaudio process (1/4)

strace of a different invocation of pulseaudio from the one that I captured the
gdb backtrace.	(Part 1 of 4)
Comment 3 Hal Duston 2007-09-22 12:16:06 EDT
Created attachment 203131 [details]
strace of pulseaudio process (2/4)

strace of a different invocation of pulseaudio from the one that I captured the
gdb backtrace.	(Part 2 of 4)
Comment 4 Hal Duston 2007-09-22 12:16:52 EDT
Created attachment 203141 [details]
strace of pulseaudio process (3/4)

strace of a different invocation of pulseaudio from the one that I captured the
gdb backtrace.	(Part 3 of 4)
Comment 5 Hal Duston 2007-09-22 12:17:26 EDT
Created attachment 203151 [details]
strace of pulseaudio process (4/4)

strace of a different invocation of pulseaudio from the one that I captured the
gdb backtrace.	(Part 4 of 4)
Comment 6 Lennart Poettering 2007-09-23 20:16:22 EDT
This is a bug in glibc and has been reported already.

*** This bug has been marked as a duplicate of 284171 ***

Note You need to log in before you can comment on or make changes to this bug.