Bug 301801 - mail function requires local MSA
mail function requires local MSA
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-updatesd (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-22 16:49 EDT by Pierre Ossman
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 00:41:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2007-09-22 16:49:35 EDT
I've been wondering for some time why I can't get the mail function in
yum-updatesd to work, and I finally decided to have a look at the code.

What I found is that it does not use the "normal" way of sending mail by
invoking "sendmail", but instead tries to do it via SMTP. To make things worse,
you cannot configure which SMTP server it should talk to, so you have to have a
MSA running locally on each and every machine.

Please fix into something more sane

(Also, changing the default address to "root" instead of "root@localhost" would
also be nice and more in line with other software and also make it work directly
with more mail systems)
Comment 1 Jeremy Katz 2007-09-24 00:41:22 EDT
As it turns out, all of the above has been implemented for F8 :)
Comment 2 Pierre Ossman 2007-09-24 00:59:13 EDT
Any change of a backport? :)

Note You need to log in before you can comment on or make changes to this bug.