Bug 3019 - NFS doesn't work with version 3 clients
Summary: NFS doesn't work with version 3 clients
Status: CLOSED DUPLICATE of bug 2973
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: knfsd   
(Show other bugs)
Version: 6.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-24 21:59 UTC by rshapiro
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-25 15:23:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description rshapiro 1999-05-24 21:59:30 UTC
There is a problem in the interaction between the Kernel
nfsd and the rpc.mountd command. The kernel provides
services for NFS version 2, but rpc.mountd registers itself
as supporting version 1,2 and 3. This causes an NFS3 client
(like SGI IRIX) to try to mount a linux filesystem using
version 3, but whenever it tries to do any actual I/O on the
filesystem, the I/O fails with a version error.

I worked around the bug by fixing the NFS startup script to
pass -V 2 -N 3 as arguments to rpc.mountd.

A better fix would of course be to add support for NFS V3.
It looks like there are bits and pieces of it in the kernel
sources, but they did not seem to make it into the build.

Comment 1 Jeff Johnson 1999-05-25 15:23:59 UTC
*** This bug has been marked as a duplicate of 2973 ***


Note You need to log in before you can comment on or make changes to this bug.