Bug 302071 - java-1.7.0-icedtea-plugin does not work for IRC applets
java-1.7.0-icedtea-plugin does not work for IRC applets
Status: CLOSED DUPLICATE of bug 304031
Product: Fedora
Classification: Fedora
Component: java-1.7.0-icedtea (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
Depends On: 304031
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-23 03:53 EDT by drago01
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-15 10:38:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drago01 2007-09-23 03:53:28 EDT
Description of problem:

I have tested the icedtea plugin and it worked fine so far. The only problem
with it is that it does not work with IRC applets due to a permission issue. The
sun plugin ask in this cases if I trust the site and if yes connects. Icedtea
just refuses to connect.

Version-Release number of selected component (if applicable):

1.7.0.0-0.15.b19.snapshot.fc8

How reproducible:

always

Steps to Reproduce:
1. try to connect to a irc java applet (ex: http://www.jwirc.com/chat.html)
2. icedtea will not connect due to permission issues
  
Actual results:

resfuses to connect due to permission issues

Expected results:

ask the user if he trust the site and if he says yes connect (same as the plugin
from sun)
Comment 1 Thomas Fitzsimmons 2007-09-24 17:57:19 EDT
The IcedTea plugin does not have support for signed applets.  As an inconvenient
workaround, you could allow all the failing permissions that you need in:

/usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0/jre/lib/security/java.policy
Comment 2 Thomas Fitzsimmons 2007-10-15 10:38:19 EDT

*** This bug has been marked as a duplicate of 304031 ***

Note You need to log in before you can comment on or make changes to this bug.