Bug 302121 - Slow download speed
Slow download speed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: d4x (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-23 05:40 EDT by Grégory SCHMITT
Modified: 2008-02-15 21:07 EST (History)
0 users

See Also:
Fixed In Version: 2.5.7.1-8.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 21:07:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix slow downloading speed in D4X (41.69 KB, patch)
2007-09-23 05:40 EDT, Grégory SCHMITT
no flags Details | Diff

  None (edit)
Description Grégory SCHMITT 2007-09-23 05:40:49 EDT
Description of problem: using d4x on Fedora 7, the download speed is incredibly
slow compared to other downloading solutions, such as wget, gwget or Firefox
internal downloader.

Version-Release number of selected component (if applicable):

latest: 2.5.7.1-3

How reproducible: always.

Actual results: about 15K/s.

Expected results: about 100K/s.

Additional info: this bug has been reported in the Debian bug board, see
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=368708. I downloaded
d4x-2.5.7.1-3.src.rpm, applied the path to the source and it works perfectly
now. Please find the diff patch atatched.
Comment 1 Grégory SCHMITT 2007-09-23 05:40:49 EDT
Created attachment 203411 [details]
Patch to fix slow downloading speed in D4X
Comment 2 Matthias Saou 2007-09-24 08:22:02 EDT
I've just tested d4x on F7 x86_64, and speed is fine for me (I get 7MB/s from a
Fedora DVD image on ftp.free.fr). The patch you attached contain only 3 possibly
relevant changes, then a lot of translation updates...

I've double checked the relevant bits, tested an updated package which still
works fine for me, and will include them in the devel package and an F7 update.
Note that d4x currently doesn't rebuild against devel because of some gtk file
selector errors...
Comment 3 Fedora Update System 2008-02-03 14:57:33 EST
d4x-2.5.7.1-8.fc7 has been submitted as an update for Fedora 7
Comment 4 Fedora Update System 2008-02-07 16:02:55 EST
d4x-2.5.7.1-8.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update d4x'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-1418
Comment 5 Fedora Update System 2008-02-15 21:07:14 EST
d4x-2.5.7.1-8.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.