Bug 302201 - updatedb.conf prunepaths error
updatedb.conf prunepaths error
Status: CLOSED DUPLICATE of bug 242715
Product: Fedora
Classification: Fedora
Component: mlocate (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Miloslav Trmač
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-23 10:38 EDT by Carl Preddy
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-23 11:41:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Preddy 2007-09-23 10:38:48 EDT
Description of problem:
updatedb fails with an assertion error when run from command line

Version-Release number of selected component (if applicable): mlocate 0.18

How reproducible: completely


Steps to Reproduce:
1.from root terminal enter "updatedb" 
 
Actual results: aborts with this message:
updatedb: src/updatedb.c:730: scan_cwd: Assertion `name_size > 1' failed.

Expected results: silent completion

Additional info: Here is the fix: 
Both F8test1 and F8test2 deliver /etc/updatedb.conf with this config statement:
PRUNEPATHS = "/afs /media /net /sfs /tmp /udev /var/spool/cups /var/spool/squid
/var/tmp"
The 4th element is wrong. After changing to "/sys" the problem is avoided.
I found a mention of this in 242715, but felt it might have been overlooked.
It seems that this error can manifest from multiple potential sources when
scanning deep into the system. I straced my instance to the /usr/share/locale/
directory but didn't get as far as the exact causer.
Comment 1 Miloslav Trmač 2007-09-23 11:41:40 EDT
Thanks for your report.

As https://bugzilla.redhat.com/show_bug.cgi?id=242715#c21 says, /sfs is separate
from /sys.  The invalid dentry in /sys should be fixed in the kernel, adding
/sys is just a work-around.

*** This bug has been marked as a duplicate of 242715 ***

Note You need to log in before you can comment on or make changes to this bug.