Bug 302241 - Autohinter+ligatures problem
Autohinter+ligatures problem
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-23 12:47 EDT by Nicolas Mailhot
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 02:14:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2007-09-23 12:47:31 EDT
Description of problem:

It seems the freetype autohinter has a problem with ligatures. When you type a
suite of fffff in a text box that uses a font including ligatures (like DejaVu
sans) you'll see the autohinter size "ff" and "f" differently

Version-Release number of selected component (if applicable):

freetype-2.3.5-3.fc8.x86_64
Comment 1 Behdad Esfahbod 2007-09-24 02:14:08 EDT
Yeah, seen that.  I'm guessing that autohinter doesn't know about ff.

But, upstream please.  I'm not going to hack on freetype here.
Comment 2 Nicolas Mailhot 2007-09-24 03:56:10 EDT
Can you point me to a bug tracker upstream cares about? Or use your powers as
Fedora maintainer to get upstream to create a category on freedesktop.org?

Fedora hits a ton of autohinter problems since other distros just use the
patent-encumbered engine, and the reports are just blackholed right now
Comment 3 Behdad Esfahbod 2007-09-28 17:25:57 EDT
http://savannah.nongnu.org/projects/freetype
Comment 4 Nicolas Mailhot 2007-09-29 03:46:54 EDT
yay for the reformated sourceforge issue manager.
No wonder there's only 21 open issues :(

Note You need to log in before you can comment on or make changes to this bug.