Bug 3023 - EGCS / GCC bug
EGCS / GCC bug
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: egcs (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-24 22:34 EDT by kumarsri
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-25 09:57:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kumarsri 1999-05-24 22:34:48 EDT
This looks like a EGCS bug to me:

#include "stdio.h"
FILE *prerror = stderr;
main() {
}

Put the above lines in a.c and type
gcc -c a.c

Gives error - initializer is not a constant

This used to work with Redhat 5.2 and it also works with
SCO Unix, Solaris, IRIX, AIX etc.
Comment 1 Bill Nottingham 1999-05-25 09:57:59 EDT
It's not an egcs bug. It's part of glibc 2.1;
stdin/stdout/stderr are *NOT* constants, so you
can't do initialization like that. Initialize the
filehandle when you use it to stderr if you like...

From the GLIBC FAQ:

I get compiler messages "Initializer element not constant" with
stdin/stdout/stderr. Why?

Constructs like:
    static FILE *InPtr = stdin;
lead to this message. This is correct behaviour with glibc since stdin
is not a constant expression. Please note that a
strict reading of ISO C does not allow above constructs.

One of the advantages of this is that you can assign to stdin, stdout,
and stderr just like any other global variable
(e.g. `stdout = my_stream;'), which can be very useful with custom
streams that you can write with libio (but
beware this is not necessarily portable). The reason to implement it
this way were versioning problems with the
size of the FILE structure.

To fix those programs you've got to initialize the variable at run
time. This can be done, e.g. in main, like:

static FILE *InPtr; int main(void) { InPtr = stdin; }

or by constructors (beware this is gcc specific):

static FILE *InPtr;
static void inPtr_construct (void) __attribute__((constructor));
static void inPtr_construct (void) { InPtr = stdin; }

Note You need to log in before you can comment on or make changes to this bug.