Bug 30240 - IRQ conflict in installation kernel makes SCSI controller unusable
IRQ conflict in installation kernel makes SCSI controller unusable
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ingo Molnar
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-01 20:28 EST by jfm2
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-16 07:54:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jfm2 2001-03-01 20:28:08 EST
My CD reader is attached to an SCSI controller.  The controller  (a Symbios
53c875) happens to use the same IRQ 9 than my ethernet card.   Both devices
are PCI.  When I try to install there is amessage telling there is an IRQ
conflict and from then installation goes so slowly to be completely
unusable: itr takes over five minutes to get a shell prompt in console 2. 
 Box is a K6/2 450 with 128 megs of RAM.

I installed through a disk install (disk is IDE) and the production kernel
does not have problems with both devices using the same IRQ.
Comment 1 Michael K. Johnson 2001-03-01 22:06:41 EST
Which ethernet card and driver?
Comment 2 jfm2 2001-03-02 17:29:42 EST
NE2000 PCI clone.  Driver is NE2K PCI.  But the problem is not in the driver. 
The problem is in PCI-related code. The kernel in kerrnel-BOOT (ie the one used
for installation) does not know how to handle peripherals using the same IRQ. 
cat /proc/pci shows that the SCSI controller has been identified as master
capable and the ethernet as not master capable (both correct) but kernel is not
able to  handle IRQ sharing.   The regular production kernel (kernel-i586 RPM)
has no problem sharing IRQs.
Comment 3 Michael K. Johnson 2001-03-05 12:43:23 EST
Could you please type the *exact* message you get telling you about
the IRQ conflict?  That way we can look for it.
Comment 4 jfm2 2001-03-08 17:11:26 EST
<4> IRQ 9 Routing conflict in PIRQ table device 00:07:2
Comment 5 Michael K. Johnson 2001-03-12 23:00:53 EST
The closest I can find is "IRQ routing conflict in pirq table for device..."

Ingo, can you shed any light on this?
Comment 6 Ingo Molnar 2001-04-16 05:38:15 EDT
does this still happen if you use the vanilla 2.4.3 kernel? There were some
fixes in this area. The pirq routing conflict is not necesserily a unrecoverable
problem, but it's indeed a sign of BIOS wackiness in the PCI area.
Comment 7 jfm2 2001-04-16 07:54:21 EDT
Could be a BIOS problem but it works with the normal (ie not install kernel).  I
think the Wolverine kernel had not the "Enable IRQ sharing" compil falg enabled
while the production kernel had it enabled

Note You need to log in before you can comment on or make changes to this bug.