Bug 302471 - Unable to boot x86 fc7xen on x86_64 hardware.
Unable to boot x86 fc7xen on x86_64 hardware.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Eduardo Habkost
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-23 21:59 EDT by Adam Greenberg
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.6.20-2943.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 20:46:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output from xen boot (27.36 KB, text/plain)
2007-09-25 21:06 EDT, Adam Greenberg
no flags Details
messages log file from fc7xen boot (47.79 KB, text/plain)
2007-09-25 21:30 EDT, Adam Greenberg
no flags Details

  None (edit)
Description Adam Greenberg 2007-09-23 21:59:55 EDT
Description of problem:
I am unable to boot a xen kernel (either 2.6.20-2925.9.fc7xen or
2.6.20-2931.fc7xen) on my quad core Intel x86_64 box.  When I try the boot fails
with a modprobe error.  Unfortunately, I do not know how to enable logging to
record this for debugging purposes (boot.log is always empty).

Version-Release number of selected component (if applicable):
xen-3.1.0-2.fc7


How reproducible:
Always occurs.


Steps to Reproduce:
1.  Install the x86 FC7 image on the x86_64 box.
2.  Include virtualization in the installation
3.  Attempt to boot the xen image.
  
Actual results:
Boot fails with a modprobe error.


Expected results:
Xen enabled kernel should boot.  Note that it does boot if I install x86_64 fc7
instead.



Additional info:
I don't know how to record this boot issue.  /var/log/boot.log is always empty.
Comment 1 Richard W.M. Jones 2007-09-24 06:56:22 EDT
Please boot, adding 'noreboot' to the Xen command line, then write down
the error or take a snapshot.
Comment 2 Adam Greenberg 2007-09-25 21:06:25 EDT
Created attachment 206301 [details]
dmesg output from xen boot

When I added the noreboot, the system eventually booted.  Here is the dmesg
log.  When the boot failed, it stopped after displaying line 568 (floppy0: no
floppy controllers found) and displayed a sys/modprobe error before that line.
Comment 3 Adam Greenberg 2007-09-25 21:30:55 EDT
Created attachment 206311 [details]
messages log file from fc7xen boot

Here is a bit more.  I removed the noreboots and the boot hung in the same
place.	I discovered that if I press the Print Screen / SysRq key, the boot
will continue.	This attachment contains the messages log that contains more
information than the previous dmesg log.  This contains a modprobe error at the
place that I see it when the boot hangs.
Comment 4 Eduardo Habkost 2007-09-26 13:19:29 EDT
It is being caused by the Firewire stack trying to use DMA in a way not 
currently supported by the Xen kernel.

The firewire stack was supposed to be disabled on the Xen kernel. You can work 
around the problem by removing the firewire modules 
under /lib/modules/2.6.20-2931.fc7xen/kernel/firewire.
Comment 5 Eduardo Habkost 2007-09-26 13:36:23 EDT
Cloned as bug #307461 for Rawhide / Fedora 8.
Comment 6 Eduardo Habkost 2007-09-26 15:04:41 EDT
Fix (disabling Firewire on i686 .config) committed to CVS. Will go to next 
Fedora 7 kernel-xen update (version 2.6.20-2937.fc7 or higher).
Comment 7 Fedora Update System 2007-11-09 18:38:25 EST
kernel-xen-2.6-2.6.20-2943.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel-xen-2.6'
Comment 8 Fedora Update System 2007-11-28 20:45:57 EST
kernel-xen-2.6-2.6.20-2943.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.