Bug 30250 - AIC-7xxx "probably out of disk space" false report
AIC-7xxx "probably out of disk space" false report
Status: CLOSED DUPLICATE of bug 30822
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-01 21:35 EST by R P Herrold
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-28 10:26:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2001-03-01 21:35:31 EST
7.1 RC1 - HP NetServer 5/100 failure (fwd)

Adaptec AIC-7xxx modules -- all SCSI HD and CDR -- Pent class
-- 192M ram
 
Would NOT boot from CD -- fell back to a 7.1RC1 boot.img
floppy
 
"Unknown video card" fallback to text display
 
It DID detect the SCSI controller without problem or
intervention
 
Two failed installs -- first with a prior installation of
7.1B2, second after wiping the partition table using DD.
                                                       
Same error both times
 
    "An error occurred transferring the install image to your
hard drive.  You are probably out of disk space."
 
But in VC 2, there is a RH partitioned 9G HD ... with what
appears to be plenty of room ...
 
---------------------
 
Used both MM Media, and a CDR burned from a D/L .iso set --
md5summed OK for both.                       

---------------------
 
The MM media similarly worked -- except for dying at the end
of the first CD, due to the physical size limit issues of the
CD image relative to the CD drive -- in a different HP
NetServer 4/66 - 486-100, 64M, AIC-7xxx controlled, fallback
to text, etc ...
 
---------------------
Comment 1 Michael Fulbright 2001-03-02 11:32:15 EST
Did 7.0 work on this system?
Comment 2 Glen Foster 2001-03-02 12:41:25 EST
We (Red Hat) really need to fix this before next release.
Comment 3 R P Herrold 2001-03-04 13:50:09 EST
Question was:  Did this work on a RH 7.0 system? -- ANSWER (From a reinstall
YES) -- BUT ...

In doing a reinstall with the 'trade show handout' 7.0 CD, (rather than the
Boxed set CD) -- I an getting the same error -- IT also is able to get graphic
mode going with this card (but I do not care either way) in checking the other
VC when it produces the same error in an X display -- it turns out there are
LOTS of reset errors on the CD drive -- Restarted in text mode and the same
errors recur -- change to two other CD's -- otherwise believed good -- and I
still get the errors ...

I infer Anaconda is not checking for hardware errors returning from the read,
and so misreporting a lack of space when there is a hardware problem running the
drive -- notice that I do NOT say that the drive is bad -- I really doubt that I
would pull three otherwise fine CD drive's from my hardware collection in a row.

This instead looks like a deeper problem in the AIC 7xxx driver reset logic.



Comment 4 R P Herrold 2001-03-04 13:50:44 EST
... Trying 7.1 RC 2 ...
Comment 5 R P Herrold 2001-03-04 14:05:49 EST
Before doing 7.1RC2, I tried a trayless SCSI drive with commecially pressed
media (OpenBSD 2.8), and the errors at the image transfer phase were not
observed with it ...  hmmm ... have you looked at their variant of the driver (I
would note that their devel traffic has had some post OBSD 2.8 trouble with some
later Adaptec controller versions)?
Comment 6 R P Herrold 2001-03-04 14:33:25 EST
Next try -- locally burned 71.RC2 from md5summed verified CD --- burned on a 4x
Philips IDE burner -- IBM marque media - 80M labelled blank -- would not boot
from CD image -- building boot.img
Comment 7 R P Herrold 2001-03-04 16:19:10 EST
It is reading the non-carrier version SCSI CD drive with 7.1RC2/s AIC-7xxx -- it
is deadly slow in the process -- running with 192 Meg ram on a P-100 - it spent
15 minutes reading the package list -- another 10 resolving dependencies ... on
a upgrade from the reinstall of RH 7.0 trade show ... 

But otherwise a successful upgrade from RH 7.0 
Comment 8 R P Herrold 2001-03-06 10:32:00 EST
uhhh ... that was an 800M labelled blank, of course --

In testing on the HP NetServer 4/66 at my office with the same media, I am also
getting the (false) reports still.

INTERESTINGLY -- if I let the host sit for 5 minutes in the error message about
the read error, (and let ALL controller activity die off), about 2/3 of the
time, it is able to read the otherwise 'corrupt' file.

Obviously the media and the drive have not changed -- just the load on the
controller and the retry queue depth.

-------------------------

I was reviewing the most recent kernel traffic ML summary, and AIC-7xxx driver
changeover to the Adaptec was under heavy discussion.  The summarized thread
about supporting older controllers seems very germaine to what we are
experiencing here.  Let me know if you need a referral ...

-------------------------

Let me know if there is an updated image test procedure which you wish me to
test on my test units.

-------------------------

Thinking back to the last test cycle for 7.0, I was experiencing extremely lony
installs -- a couple of hours with an older 2740UW controller in a dual pentium
host -- I thought it was an RPM issue, and discussed it with JBJ ... perhaps it
was really this issue.
Comment 9 R P Herrold 2001-03-06 11:00:00 EST
In testing further, the pattern most likely to succeeed with the present
AIC-7xxx driver is:

1.  it fails ... and displays the error message box
2.  wait 5 minutes
3.  hit enter -- it either works, or fails at once with out a retry
4.  immediately rehit enter if it refails -- often works at the second try
Comment 10 R P Herrold 2001-03-06 11:51:59 EST
Installed just dies after 24 hr with an anaconda traceback -- I'll file
separately to get another Bugzilla number, and note here (frown) -- it was
installing emancs libraries -- roughly 83 packages to go of 4xx total ...

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=30822
Comment 11 Michael Fulbright 2001-03-28 10:26:51 EST
Matt please investigate.
Comment 12 Matt Wilson 2001-03-28 11:46:27 EST

*** This bug has been marked as a duplicate of 30822 ***

Note You need to log in before you can comment on or make changes to this bug.