Bug 302521 - own %{_datadir}/ghostscript/conf.d
own %{_datadir}/ghostscript/conf.d
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: filesystem (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-24 00:11 EDT by Jens Petersen
Modified: 2015-03-04 20:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 08:11:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2007-09-24 00:11:46 EDT
Description of problem:
It would be nice if filesystem could own %{_datadir}/ghostscript/conf.d
since it is used by a number of fonts which should not have to require
ghostscript.

Steps to Reproduce:
1. rpm -qf /usr/share/ghostscript/conf.d
  
Actual results:
ghostscript and some fonts

Expected results:
filesystem, so that ghostscript does not have to be installed.
Comment 1 Mamoru TASAKA 2007-09-24 00:42:51 EDT
Also I think %_datadir/ghostscript/conf.d should be owned by
filesystem. 

But in this case as %_datadir/ghostscript is the
parent directory, I think %_datadir/ghostscript should also be owned
by filesystem (to avoid ghostscript dependency).
Comment 2 Phil Knirsch 2008-03-27 11:37:04 EDT
filesystem doesn't so far contain any directly application related files, so i'm
not in favor of adding /usr/share/ghostscript/conf.d or even
/usr/share/ghostscript to it.

If the fonts would be moved to another location which ghostscript would also use
that would be something different though (e.g. /usr/share/fonts will be owned by
filesystem with the next build).

Read ya, Phil
Comment 3 Jens Petersen 2008-04-09 03:05:28 EDT
The files in /usr/share/ghostscript/conf.d are not fonts
but config files related ghostscript: mostly font aliases for CJK fonts
AFAICS.
Comment 4 Bug Zapper 2008-05-13 23:16:07 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Tony Fu 2008-09-09 23:09:41 EDT
requested by Jens Petersen (#27995)
Comment 6 Phil Knirsch 2009-03-04 08:11:15 EST
Talked a long time with the ghostscript owner yesterday about it and we came to the same conclusion that unfortunately having those directories owned by filesystem would be the best (yet still ugly) solution.

Added it to the latest filesystem package for rawhide.

Thanks & regards, Phil

Note You need to log in before you can comment on or make changes to this bug.