Bug 30298 - dhcp config error
Summary: dhcp config error
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-02 13:29 UTC by Matthew Mahoney
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-02 13:29:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Mahoney 2001-03-02 13:29:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)


This is not a bug (I don't think) but I get an error when I try to start 
the DHCPD service.  I have looked for references in the RH 7 book but 
cannot find any.  It seems that whatever the line that is missing is not 
required in RH 6.  The error is:

No subnet declaration for eth0 (168.192.0.254)
Please write a subnet declaration for the network segment to whech 
interface eth0 is attached

exiting

HELP!

Reproducible: Always
Steps to Reproduce:
1.dhcpd start
2.
3.
	

.

Comment 1 Bill Nottingham 2001-03-02 17:38:27 UTC
You need subnet delacarations in your dhcpd.conf for all your network
interfaces; my best suggestion is to look at the man page for documentation
on how to set it up.

Comment 2 Matthew Mahoney 2001-03-02 18:47:34 UTC
I have consulted the man page for dhcpd.conf.  I haven't found an example on 
how to create a subnet declaration for eth0.  Here is my dhcpd.conf file:

subnet 192.168.0.0 netmask 255.255.255.0 {
# --- default gateway

range dynamic-bootp 192.168.0.1 192.168.0.250;
	default-lease-time 21600;
	max-lease-time 43200;
	server-identifier		matty;
	option routers			192.168.0.254;
	option subnet-mask		255.255.255.0;
		
	option time-offset		-5;	# Eastern Standard Time

#	option ntp-servers		192.168.1.1;
#	option netbios-name-servers	192.168.1.1;
# --- Selects point-to-point node (default is hybrid). Don't change this unless
# -- you understand Netbios very well
#	option netbios-node-type 2;

	# we want the nameserver to appear at a fixed address
	host matty {
		hardware ethernet 00:E0:81:01:54:05;
		fixed-address 192.168.0.254;
	}
}



Note You need to log in before you can comment on or make changes to this bug.