Bug 303061 - mailman reformats headers in multipart/signed, breaking the signature
mailman reformats headers in multipart/signed, breaking the signature
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mailman (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-24 10:00 EDT by Tomas Janousek
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 10:40:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Janousek 2007-09-24 10:00:09 EDT
Description of problem:
$summary

Version-Release number of selected component (if applicable):
2.1.5, 2.1.9, whatever.

How reproducible:
wget http://people.redhat.com/tjanouse/mailman/test.eml
/usr/sbin/sendmail mailman@localhost <test.eml
Then check whether the signature is correct -- it's busted in the email mailman
delivers to the list or, if it bounces it to the list admin, it's busted even in
the attachment.

Additional info:
There's a patch[1] in Debian that disables the header folding for all headers
except the top headers (in particular, it does not fold any headers inside
multipart subparts). I'm not sure whether this is completely correct, since we
may want to fold headers generated by mailman itself -- and these may occur in
multipart subparts.

Other solution may be not to fold headers in multipart/signed (and possibly some
other) payloads. This is something that I hopefully achieved in this patch[2].
It touches a code that doesn't really belong to Mailman and I'm not sure whether
it covers all (or no more than desirable) cases.

And the best solution would probably be to track the headers we changed/added
and fold only those. This is msivak's idea and he seemed to feel like
implementing it, Cc'ing him then.

(This bug should probably be filled against Python and there probably is a
number of upstream bugs about it, but Debian has a workaround in the mailman
package anyway, so ...)

[1] http://people.redhat.com/tjanouse/mailman/77_header_folding_in_attachments.patch
[2] http://people.redhat.com/tjanouse/mailman/mailman-multipart-signed.patch
Comment 1 Tomas Smetana 2007-10-24 10:40:19 EDT
Commited and build in devel branch with patch [1].  If someone had a better one
feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.