Bug 303091 - Make the Wireless Auth box more intuitive
Make the Wireless Auth box more intuitive
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-24 10:04 EDT by Pete Graner
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-04 13:43:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Graner 2007-09-24 10:04:16 EDT
Description of problem:

When connecting to a protected AP NM pops up a box titled "Wireless Network Key
Required" 

When you type in your password, instead of dots it shows the password.

Additionally the "Connect" Button never lites up, the only option left is the
"Cancel" button. When you click it it core dumps nm dies and bug buddy pops up.


Version-Release number of selected component (if applicable):

[pgraner@moltar ~]$ rpm -q NetworkManager
NetworkManager-0.7.0-0.3.svn2852.fc8

[pgraner@moltar ~]$ rpm -q dbus
dbus-1.1.2-6.fc8

[pgraner@moltar ~]$ rpm -q gnome-keyring
gnome-keyring-2.20-1.fc8

How reproducible: 100%

I would attach the bug buddy output, but it does not give it to me, just some
bizarre message about it collecting it but it can't send it to the gnome server.
Comment 1 Pete Graner 2007-09-24 10:06:05 EDT
starting nm-applet from the command line gives this output:

[pgraner@moltar ~]$ ** Message: NM appeared
** (nm-applet:4161): WARNING **: Found connection Auto rh-wireless to activate
at /org/freedesktop/NetworkManagerSettings/0.
** Message: <info>  No keyring secrets found for Auto
rh-wireless/802-11-wireless-security; ask the user

process 4161: arguments to dbus_message_new_error() were incorrect, assertion
"_dbus_check_is_valid_error_name (error_name)" failed in file dbus-message.c
line 1207.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace
05433fd8-851e-4de4-19b32c02-17388d96 is dumped
Comment 2 Chris Bagwell 2007-09-26 22:00:59 EDT
This is a "me too".  I had NetworkManager working in F8T2 with my WEP connection
using ndiswrapper.  It had the annoying Keyring prompt before I connected first
time.  I was happy to see the upgrade to 0.7 in hopes that prompt would go away.

After doing a yum update to the newer NetworkManager, I get the above described
behavior during the "Wireless Network Key Required" dialog.  I'm not sure if
this is caused by the pre-existing keyring values but I'd think it should handle
upgrades.

I think the "summary" of this bug should probably be updated slightly.  I'm less
concerned about the password in clear text but the fact that "Connect" is greyed
out doesn't let me connect to my AP.
Comment 3 Pete Graner 2007-09-27 07:08:06 EDT
So after dorking with this for a bit, I realized this is not the keyring
password, its actually asking for the WEP password and the "Connect" button
won't light up until you put in all 26 (I think) hex chars. Then you can click
connect, then the keyring password box pops up.

This is a different behavior from previous where you couldn't do crap with a WEP
access point until you gave it your keyring password.

The WEP box should be changed so that its more obvious that its looking for a
wep key. Prior it would give you numerous options (WEP 48/128 bit....), now its
just a text field. I'm gussing the the supplicant below just knows what to do
based on the string so they gleeped out the pick list of auth methods. But I
don't know for sure.

It does work now, so I'm changing the summary to be, "Make the Wireless Auth box
more intuitive"
Comment 4 Matthias Clasen 2007-09-27 13:42:23 EDT
I'm pretty sure that this is just a red-tape ui until dan has fixed up the real
thing.
Comment 5 Jeremy Katz 2007-09-28 17:33:07 EDT
The text is now
  Password Required by Wireless Network
  
  A passphrase or encryption key is required to access the wireless network
'e=mc^2'.
 
   Password: [_____________]

with the same title.  Does that seem better to you (seems pretty clear to me)?
Comment 6 Chris Bagwell 2007-09-28 22:14:28 EDT
Yes, it is much more clear to me now that the question is not for Keyring but
for Network key.  Also, I can verify that with latest NetworkManager that the
nm-applet no longer crashes as reported above when you select "Cancel".  

So actually two separate issues are resolved now.

I still have some outstanding issue where I can associated but I can't get an IP
address from DHCP.  Used to work before 0.7 upgrade.  I'll try to find out more
information and either write a new bug report or look for another pre-existing.
 Seem to be unique to me as Commnet #3 says its working for them.
Comment 7 Pete Graner 2007-09-29 12:12:49 EDT
Looks much better now. Like in #6 above I'm having the same, not getting an IP
when associated as well.
Comment 8 Chris Bagwell 2007-10-01 10:52:27 EDT
With the update of NetworkManager as of today I can now connect to my AP's
again.   So my issues described in Comment #6 is resolved. Looks like I'm back
to pre-0.7 state now.

Well, one thing does seem to not be working.  When I unplugged my wired
connection, I get a notification message about the disconnect but NetworkManager
doesn't automatically switch to a wireless network.  I have to manually pick
one.  I think there may be other bug reports that already mention this (I think
I saw something on the test mailing list).
Comment 9 Jeremy Katz 2007-10-04 13:43:03 EDT
Chris -- the not autoconnecting thing is tracked in a separate bug. 

Thanks for the feedback everyone; closing this one out.

Note You need to log in before you can comment on or make changes to this bug.